summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2022-09-12 16:59:11 -0400
committerBruce Ashfield <bruce.ashfield@gmail.com>2022-09-12 16:59:26 -0400
commitc991546a7f82b1a430413e241a7baf3dd632d1ae (patch)
treed7d1bdf6e218ab1210a10848c267de5a35f03fa3
parentf20516d0fd0ddfb9e2f4d2bdb11ea40ccf575d49 (diff)
downloadmeta-virtualization-c991546a7f82b1a430413e241a7baf3dd632d1ae.tar.gz
k3s: pass -trimpath to improve reproducibility
-rw-r--r--recipes-containers/k3s/k3s_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-containers/k3s/k3s_git.bb b/recipes-containers/k3s/k3s_git.bb
index 66ff523b..957693ce 100644
--- a/recipes-containers/k3s/k3s_git.bb
+++ b/recipes-containers/k3s/k3s_git.bb
@@ -683,7 +683,7 @@ do_compile() {
683 683
684 cp ${WORKDIR}/modules.txt vendor/ 684 cp ${WORKDIR}/modules.txt vendor/
685 685
686 ${GO} build -tags "$TAGS" -ldflags "${GO_BUILD_LDFLAGS} -w -s" -o ./dist/artifacts/k3s ./cmd/server/main.go 686 ${GO} build -trimpath -tags "$TAGS" -ldflags "${GO_BUILD_LDFLAGS} -w -s" -o ./dist/artifacts/k3s ./cmd/server/main.go
687 687
688 # Use UPX if it is enabled (and thus exists) to compress binary 688 # Use UPX if it is enabled (and thus exists) to compress binary
689 if command -v upx > /dev/null 2>&1; then 689 if command -v upx > /dev/null 2>&1; then