summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2022-09-12 14:36:56 -0400
committerBruce Ashfield <bruce.ashfield@gmail.com>2022-09-12 14:36:56 -0400
commit08a59b4d934f601307d0a3cb9ab3a835904baecb (patch)
treebf9aa5cac863c909b45417a48c957c9aaaa65357
parent7106007c147c34aca9551c5e450851655623f991 (diff)
downloadmeta-virtualization-08a59b4d934f601307d0a3cb9ab3a835904baecb.tar.gz
nerdctl: reproducibility, path -trmpath to build
To avoid go embedding references to the build dir into binaries, we pass -trimpath to the build. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-containers/nerdctl/nerdctl_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-containers/nerdctl/nerdctl_git.bb b/recipes-containers/nerdctl/nerdctl_git.bb
index d5e28e14..4a749b27 100644
--- a/recipes-containers/nerdctl/nerdctl_git.bb
+++ b/recipes-containers/nerdctl/nerdctl_git.bb
@@ -64,7 +64,7 @@ do_compile() {
64 export CGO_CFLAGS="${CFLAGS} --sysroot=${STAGING_DIR_TARGET}" 64 export CGO_CFLAGS="${CFLAGS} --sysroot=${STAGING_DIR_TARGET}"
65 export CGO_LDFLAGS="${LDFLAGS} --sysroot=${STAGING_DIR_TARGET}" 65 export CGO_LDFLAGS="${LDFLAGS} --sysroot=${STAGING_DIR_TARGET}"
66 66
67 export GOFLAGS="-mod=vendor" 67 export GOFLAGS="-mod=vendor -trimpath"
68 68
69 # this moves all the fetches into the proper vendor structure 69 # this moves all the fetches into the proper vendor structure
70 # expected for build 70 # expected for build