summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Clark <christopher.w.clark@gmail.com>2021-08-23 22:10:27 -0700
committerBruce Ashfield <bruce.ashfield@gmail.com>2021-08-27 10:50:45 -0400
commitc8e57e4f22b299c1eb65ade4f2a3f43102c3c735 (patch)
tree6be5afa8d0240fe76b942dde658763ecedcb2103
parente9fa487c3bca947ecbe3a34d0cc4896ba7591d32 (diff)
downloadmeta-virtualization-c8e57e4f22b299c1eb65ade4f2a3f43102c3c735.tar.gz
xen, xen-tools: apply workaround for gnu linker error to fix x86 build
Upstream patch applied to each Xen and Xen tools recipe to fix the build of the hypervisor and shim with GNU linker 2.37. Signed-off-by: Christopher Clark <christopher.w.clark@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-extended/xen/files/0001-x86-work-around-build-issue-with-GNU-ld-2.37.patch36
-rw-r--r--recipes-extended/xen/xen-tools_4.14.bb1
-rw-r--r--recipes-extended/xen/xen-tools_4.15.bb1
-rw-r--r--recipes-extended/xen/xen-tools_git.bb1
-rw-r--r--recipes-extended/xen/xen_4.14.bb1
-rw-r--r--recipes-extended/xen/xen_4.15.bb1
-rw-r--r--recipes-extended/xen/xen_git.bb1
7 files changed, 42 insertions, 0 deletions
diff --git a/recipes-extended/xen/files/0001-x86-work-around-build-issue-with-GNU-ld-2.37.patch b/recipes-extended/xen/files/0001-x86-work-around-build-issue-with-GNU-ld-2.37.patch
new file mode 100644
index 00000000..f5108be8
--- /dev/null
+++ b/recipes-extended/xen/files/0001-x86-work-around-build-issue-with-GNU-ld-2.37.patch
@@ -0,0 +1,36 @@
1From 58ad654ebce7ccb272a3f4f3482c03aaad850d31 Mon Sep 17 00:00:00 2001
2From: Jan Beulich <jbeulich@suse.com>
3Date: Thu, 22 Jul 2021 11:20:38 +0200
4Subject: [PATCH] x86: work around build issue with GNU ld 2.37
5
6I suspect it is commit 40726f16a8d7 ("ld script expression parsing")
7which broke the hypervisor build, by no longer accepting section names
8with a dash in them inside ADDR() (and perhaps other script directives
9expecting just a section name, not an expression): .note.gnu.build-id
10is such a section.
11
12Quoting all section names passed to ADDR() via DECL_SECTION() works
13around the regression.
14
15Signed-off-by: Jan Beulich <jbeulich@suse.com>
16Acked-by: Andrew Cooper <andrew.cooper3@citrix.com>
17---
18 xen/arch/x86/xen.lds.S | 2 +-
19 1 file changed, 1 insertion(+), 1 deletion(-)
20
21diff --git a/xen/arch/x86/xen.lds.S b/xen/arch/x86/xen.lds.S
22index 9c6c1c8005..955d5cf4a0 100644
23--- a/xen/arch/x86/xen.lds.S
24+++ b/xen/arch/x86/xen.lds.S
25@@ -18,7 +18,7 @@ ENTRY(efi_start)
26 #else /* !EFI */
27
28 #define FORMAT "elf64-x86-64"
29-#define DECL_SECTION(x) x : AT(ADDR(x) - __XEN_VIRT_START)
30+#define DECL_SECTION(x) x : AT(ADDR(#x) - __XEN_VIRT_START)
31
32 ENTRY(start_pa)
33
34--
352.25.1
36
diff --git a/recipes-extended/xen/xen-tools_4.14.bb b/recipes-extended/xen/xen-tools_4.14.bb
index 6fd6f7fe..ce5dc2e8 100644
--- a/recipes-extended/xen/xen-tools_4.14.bb
+++ b/recipes-extended/xen/xen-tools_4.14.bb
@@ -9,6 +9,7 @@ SRC_URI = " \
9 file://0001-firmware-provide-a-stand-alone-set-of-headers-Xen-4.14.patch \ 9 file://0001-firmware-provide-a-stand-alone-set-of-headers-Xen-4.14.patch \
10 file://0001-tools-firmware-Build-firmware-as-ffreestanding-Xen-4.14.patch \ 10 file://0001-tools-firmware-Build-firmware-as-ffreestanding-Xen-4.14.patch \
11 file://0001-libs-foreignmemory-Fix-osdep_xenforeignmemory_map-pr.patch \ 11 file://0001-libs-foreignmemory-Fix-osdep_xenforeignmemory_map-pr.patch \
12 file://0001-x86-work-around-build-issue-with-GNU-ld-2.37.patch \
12 " 13 "
13 14
14LIC_FILES_CHKSUM ?= "file://COPYING;md5=419739e325a50f3d7b4501338e44a4e5" 15LIC_FILES_CHKSUM ?= "file://COPYING;md5=419739e325a50f3d7b4501338e44a4e5"
diff --git a/recipes-extended/xen/xen-tools_4.15.bb b/recipes-extended/xen/xen-tools_4.15.bb
index f3f9cd31..e9c3bd64 100644
--- a/recipes-extended/xen/xen-tools_4.15.bb
+++ b/recipes-extended/xen/xen-tools_4.15.bb
@@ -7,6 +7,7 @@ SRC_URI = " \
7 git://xenbits.xen.org/xen.git;branch=${XEN_BRANCH} \ 7 git://xenbits.xen.org/xen.git;branch=${XEN_BRANCH} \
8 file://0001-python-pygrub-pass-DISTUTILS-xen-4.15.patch \ 8 file://0001-python-pygrub-pass-DISTUTILS-xen-4.15.patch \
9 file://0001-libs-foreignmemory-Fix-osdep_xenforeignmemory_map-pr.patch \ 9 file://0001-libs-foreignmemory-Fix-osdep_xenforeignmemory_map-pr.patch \
10 file://0001-x86-work-around-build-issue-with-GNU-ld-2.37.patch \
10 " 11 "
11 12
12LIC_FILES_CHKSUM ?= "file://COPYING;md5=419739e325a50f3d7b4501338e44a4e5" 13LIC_FILES_CHKSUM ?= "file://COPYING;md5=419739e325a50f3d7b4501338e44a4e5"
diff --git a/recipes-extended/xen/xen-tools_git.bb b/recipes-extended/xen/xen-tools_git.bb
index 0b2dce9f..6926bd9c 100644
--- a/recipes-extended/xen/xen-tools_git.bb
+++ b/recipes-extended/xen/xen-tools_git.bb
@@ -7,6 +7,7 @@ SRC_URI = " \
7 git://xenbits.xen.org/xen.git;branch=${XEN_BRANCH} \ 7 git://xenbits.xen.org/xen.git;branch=${XEN_BRANCH} \
8 file://0001-python-pygrub-pass-DISTUTILS-xen-4.15.patch \ 8 file://0001-python-pygrub-pass-DISTUTILS-xen-4.15.patch \
9 file://0001-libs-foreignmemory-Fix-osdep_xenforeignmemory_map-pr.patch \ 9 file://0001-libs-foreignmemory-Fix-osdep_xenforeignmemory_map-pr.patch \
10 file://0001-x86-work-around-build-issue-with-GNU-ld-2.37.patch \
10 " 11 "
11 12
12LIC_FILES_CHKSUM ?= "file://COPYING;md5=419739e325a50f3d7b4501338e44a4e5" 13LIC_FILES_CHKSUM ?= "file://COPYING;md5=419739e325a50f3d7b4501338e44a4e5"
diff --git a/recipes-extended/xen/xen_4.14.bb b/recipes-extended/xen/xen_4.14.bb
index 0dd9d3c2..291ba165 100644
--- a/recipes-extended/xen/xen_4.14.bb
+++ b/recipes-extended/xen/xen_4.14.bb
@@ -7,6 +7,7 @@ SRC_URI = " \
7 git://xenbits.xen.org/xen.git;branch=${XEN_BRANCH} \ 7 git://xenbits.xen.org/xen.git;branch=${XEN_BRANCH} \
8 file://xen-arm64-implement-atomic-fetch-add.patch \ 8 file://xen-arm64-implement-atomic-fetch-add.patch \
9 file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-location.patch \ 9 file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-location.patch \
10 file://0001-x86-work-around-build-issue-with-GNU-ld-2.37.patch \
10 " 11 "
11 12
12LIC_FILES_CHKSUM ?= "file://COPYING;md5=419739e325a50f3d7b4501338e44a4e5" 13LIC_FILES_CHKSUM ?= "file://COPYING;md5=419739e325a50f3d7b4501338e44a4e5"
diff --git a/recipes-extended/xen/xen_4.15.bb b/recipes-extended/xen/xen_4.15.bb
index d0aa1761..06054418 100644
--- a/recipes-extended/xen/xen_4.15.bb
+++ b/recipes-extended/xen/xen_4.15.bb
@@ -8,6 +8,7 @@ SRC_URI = " \
8 file://xen-arm64-implement-atomic-fetch-add.patch \ 8 file://xen-arm64-implement-atomic-fetch-add.patch \
9 file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-location.patch \ 9 file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-location.patch \
10 file://0001-x86-make-hypervisor-build-with-gcc11.patch \ 10 file://0001-x86-make-hypervisor-build-with-gcc11.patch \
11 file://0001-x86-work-around-build-issue-with-GNU-ld-2.37.patch \
11 " 12 "
12 13
13LIC_FILES_CHKSUM ?= "file://COPYING;md5=419739e325a50f3d7b4501338e44a4e5" 14LIC_FILES_CHKSUM ?= "file://COPYING;md5=419739e325a50f3d7b4501338e44a4e5"
diff --git a/recipes-extended/xen/xen_git.bb b/recipes-extended/xen/xen_git.bb
index 7ce72280..12c9403b 100644
--- a/recipes-extended/xen/xen_git.bb
+++ b/recipes-extended/xen/xen_git.bb
@@ -8,6 +8,7 @@ SRC_URI = " \
8 file://xen-arm64-implement-atomic-fetch-add.patch \ 8 file://xen-arm64-implement-atomic-fetch-add.patch \
9 file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-location.patch \ 9 file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-location.patch \
10 file://0001-x86-make-hypervisor-build-with-gcc11.patch \ 10 file://0001-x86-make-hypervisor-build-with-gcc11.patch \
11 file://0001-x86-work-around-build-issue-with-GNU-ld-2.37.patch \
11 " 12 "
12 13
13LIC_FILES_CHKSUM ?= "file://COPYING;md5=419739e325a50f3d7b4501338e44a4e5" 14LIC_FILES_CHKSUM ?= "file://COPYING;md5=419739e325a50f3d7b4501338e44a4e5"