summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRicardo Salveti <ricardo@foundries.io>2020-10-30 20:14:44 -0300
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-11-03 16:30:29 -0500
commit74e0b8d2acc6b9bbc0345a500a700932d70772f4 (patch)
tree75e64d03ea9f0cadcd2d613b6cb2b5b92e53f7cb
parent2f83558f4611221baa24afb07a27cd50e26f4ae1 (diff)
downloadmeta-virtualization-74e0b8d2acc6b9bbc0345a500a700932d70772f4.tar.gz
python3-docker-compose: upgrade 1.26.0 to 1.27.4
Release notes for 1.27.4: - Bugs - Remove path checks for bind mounts - Fix port rendering to output long form syntax for non-v1 - Add protocol to the docker socket address Release notes for 1.27.3: - Bugs - Merged max_replicas_per_node on docker-compose config. - Fixed depends_on serialization on docker-compose config. - Fixed scaling when some containers are not running on docker-compose up. - Enabled relative paths for driver_opts.device for local driver. - Allowed strings for cpus fields. Release notes for 1.27.2: - Bugs - Fix bug on docker-compose run container attach Release notes for 1.27.1: - Bugs - Fix compose run when service.scale is specified - Allow driver property for external networks as temporary workaround for swarm network propagation issue - Pin new internal schema version to 3.9 as the default - Preserve the version when configured in the compose file Release notes for 1.27.0: - Features - Merge 2.x and 3.x compose formats and align with COMPOSE_SPEC schema - Implement service mode for ipc - Pass COMPOSE_PROJECT_NAME environment variable in container mode - Make run behave in the same way as up - Use docker build on docker-compose run when COMPOSE_DOCKER_CLI_BUILD environment variable is set - Use docker-py default API version for engine queries (auto) - Parse network_mode on build - Bugs - Ignore build context path validation when building is not required - Fix float to bytes conversion via docker-py bump to 4.3.1 - Fix scale bug when deploy section is set - Fix docker-py bump in setup.py - Fix experimental build failure detection - Fix context propagation to docker cli - Miscellaneous - Drop support for Python 2.7 - Add script for docs syncronization - Bump docker-py to 4.3.1 - Bump tox to 3.19.0 - Bump virtualenv to 20.0.30 Release notes for 1.26.2: - Bugs - Enforce docker-py 4.2.2 as minimum version when installing with pip Release notes for 1.26.1: - Features - Bump docker-py from 4.2.1 to 4.2.2 - Bugs - Enforce docker-py 4.2.1 as minimum version when installing with pip - Fix context load for non-docker endpoints Signed-off-by: Ricardo Salveti <ricardo@foundries.io> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch25
-rw-r--r--recipes-containers/docker-compose/python3-docker-compose_1.27.4.bb (renamed from recipes-containers/docker-compose/python3-docker-compose_1.26.0.bb)4
2 files changed, 13 insertions, 16 deletions
diff --git a/recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch b/recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch
index f517d05a..2c25f69d 100644
--- a/recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch
+++ b/recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch
@@ -1,4 +1,4 @@
1From 1d358acd46c9ca71d848fca8c2d677414257f247 Mon Sep 17 00:00:00 2001 1From e3aca6421e003d03d119e69bf3d6b30bb5c662c9 Mon Sep 17 00:00:00 2001
2From: Chen Qi <Qi.Chen@windriver.com> 2From: Chen Qi <Qi.Chen@windriver.com>
3Date: Fri, 22 Nov 2019 09:24:58 +0800 3Date: Fri, 22 Nov 2019 09:24:58 +0800
4Subject: [PATCH] setup.py: remove maximum version requirements 4Subject: [PATCH] setup.py: remove maximum version requirements
@@ -11,14 +11,14 @@ Upstream-Status: Inappropriate [OE Specific]
11Signed-off-by: Chen Qi <Qi.Chen@windriver.com> 11Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
12Signed-off-by: Ming Liu <liu.ming50@gmail.com> 12Signed-off-by: Ming Liu <liu.ming50@gmail.com>
13--- 13---
14 setup.py | 26 +++++++++++++------------- 14 setup.py | 24 ++++++++++++------------
15 1 file changed, 13 insertions(+), 13 deletions(-) 15 1 file changed, 12 insertions(+), 12 deletions(-)
16 16
17diff --git a/setup.py b/setup.py 17diff --git a/setup.py b/setup.py
18index 110441dc..eef28254 100644 18index e0d4340e..80ffefe5 100644
19--- a/setup.py 19--- a/setup.py
20+++ b/setup.py 20+++ b/setup.py
21@@ -30,18 +30,18 @@ def find_version(*file_paths): 21@@ -25,17 +25,17 @@ def find_version(*file_paths):
22 22
23 23
24 install_requires = [ 24 install_requires = [
@@ -29,9 +29,8 @@ index 110441dc..eef28254 100644
29- 'texttable >= 0.9.0, < 2', 29- 'texttable >= 0.9.0, < 2',
30- 'websocket-client >= 0.32.0, < 1', 30- 'websocket-client >= 0.32.0, < 1',
31- 'distro >= 1.5.0, < 2', 31- 'distro >= 1.5.0, < 2',
32- 'docker[ssh] >= 3.7.0, < 5', 32- 'docker[ssh] >= 4.3.1, < 5',
33- 'dockerpty >= 0.4.1, < 1', 33- 'dockerpty >= 0.4.1, < 1',
34- 'six >= 1.3.0, < 2',
35- 'jsonschema >= 2.5.1, < 4', 34- 'jsonschema >= 2.5.1, < 4',
36- 'python-dotenv >= 0.13.0, < 1', 35- 'python-dotenv >= 0.13.0, < 1',
37+ 'cached-property >= 1.2.0', 36+ 'cached-property >= 1.2.0',
@@ -41,24 +40,22 @@ index 110441dc..eef28254 100644
41+ 'texttable >= 0.9.0', 40+ 'texttable >= 0.9.0',
42+ 'websocket-client >= 0.32.0', 41+ 'websocket-client >= 0.32.0',
43+ 'distro >= 1.5.0', 42+ 'distro >= 1.5.0',
44+ 'docker[ssh] >= 3.7.0', 43+ 'docker[ssh] >= 4.3.1',
45+ 'dockerpty >= 0.4.1', 44+ 'dockerpty >= 0.4.1',
46+ 'six >= 1.3.0',
47+ 'jsonschema >= 2.5.1', 45+ 'jsonschema >= 2.5.1',
48+ 'python-dotenv >= 0.13.0', 46+ 'python-dotenv >= 0.13.0',
49 ] 47 ]
50 48
51 49
52@@ -61,7 +61,7 @@ extras_require = { 50@@ -51,7 +51,7 @@ if sys.version_info[:2] < (3, 4):
53 ':python_version < "3.3"': ['backports.shutil_get_terminal_size == 1.0.0', 51 extras_require = {
54 'ipaddress >= 1.0.16, < 2'], 52 ':python_version < "3.5"': ['backports.ssl_match_hostname >= 3.5, < 4'],
55 ':sys_platform == "win32"': ['colorama >= 0.4, < 1'], 53 ':sys_platform == "win32"': ['colorama >= 0.4, < 1'],
56- 'socks': ['PySocks >= 1.5.6, != 1.5.7, < 2'], 54- 'socks': ['PySocks >= 1.5.6, != 1.5.7, < 2'],
57+ 'socks': ['PySocks >= 1.5.6, != 1.5.7'], 55+ 'socks': ['PySocks >= 1.5.6, != 1.5.7'],
58 'tests': tests_require, 56 'tests': tests_require,
59 } 57 }
60 58
61
62-- 59--
632.25.0 602.28.0
64 61
diff --git a/recipes-containers/docker-compose/python3-docker-compose_1.26.0.bb b/recipes-containers/docker-compose/python3-docker-compose_1.27.4.bb
index 37c62e85..1096d31d 100644
--- a/recipes-containers/docker-compose/python3-docker-compose_1.26.0.bb
+++ b/recipes-containers/docker-compose/python3-docker-compose_1.27.4.bb
@@ -5,8 +5,8 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=435b266b3899aa8a959f17d41c56def8"
5 5
6inherit pypi setuptools3 6inherit pypi setuptools3
7 7
8SRC_URI[md5sum] = "f7d54de5db1f17322c09db8157bd160f" 8SRC_URI[md5sum] = "6c25d3b92596dc529edc337cc837eae1"
9SRC_URI[sha256sum] = "7e836102d139aca667d6af53f0f4d942c9459ec24d6dd4f0203d74359b0fd311" 9SRC_URI[sha256sum] = "5a5690f24c27d4b43dcbe6b3fae91ba680713208e99ee863352b3bae37bcaa83"
10 10
11SRC_URI += "file://0001-setup.py-remove-maximum-version-requirements.patch \ 11SRC_URI += "file://0001-setup.py-remove-maximum-version-requirements.patch \
12 file://0001-setup.py-import-fastentrypoints.patch \ 12 file://0001-setup.py-import-fastentrypoints.patch \