summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2021-10-22 18:46:28 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2021-10-28 15:30:19 -0400
commitf71bedc29d838cf0bcbf0856a4c7c47a51f79cb5 (patch)
treeaa1b94296892b0fee273df3c57a26b2d48ffdeb7
parente94f6cb9ab07cd0d87e1b11db207753eadd0b713 (diff)
downloadmeta-virtualization-f71bedc29d838cf0bcbf0856a4c7c47a51f79cb5.tar.gz
ceph: 15.2.12 -> 15.2.15
Update ceph to latest 15.x version: * remove 0001-add-missing-include-for-atomic-bool.patch which has been fixed in upstream * update patch to support python 3.10 * add gawk to RDEPENDS that script 'rgw-gap-list-comparator' requires it Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-extended/ceph/ceph/0001-add-missing-include-for-atomic-bool.patch25
-rw-r--r--recipes-extended/ceph/ceph/0001-cmake-add-support-for-python3.10.patch (renamed from recipes-extended/ceph/ceph/0001-cmake-add-support-for-python3.9.patch)12
-rw-r--r--recipes-extended/ceph/ceph_15.2.15.bb (renamed from recipes-extended/ceph/ceph_15.2.12.bb)9
3 files changed, 11 insertions, 35 deletions
diff --git a/recipes-extended/ceph/ceph/0001-add-missing-include-for-atomic-bool.patch b/recipes-extended/ceph/ceph/0001-add-missing-include-for-atomic-bool.patch
deleted file mode 100644
index ffcbc583..00000000
--- a/recipes-extended/ceph/ceph/0001-add-missing-include-for-atomic-bool.patch
+++ /dev/null
@@ -1,25 +0,0 @@
1From 502be73be3c3645094525aa552f5e53d8782a004 Mon Sep 17 00:00:00 2001
2From: Sakib Sajal <sakib.sajal@windriver.com>
3Date: Fri, 28 Aug 2020 19:36:19 -0400
4Subject: [PATCH] add missing include for atomic<bool>
5
6Signed-off-by: Sakib Sajal <sakib.sajal@windriver.com>
7---
8 src/tools/rbd/action/Bench.cc | 1 +
9 1 file changed, 1 insertion(+)
10
11diff --git a/src/tools/rbd/action/Bench.cc b/src/tools/rbd/action/Bench.cc
12index aa6edbc1..90c551c1 100644
13--- a/src/tools/rbd/action/Bench.cc
14+++ b/src/tools/rbd/action/Bench.cc
15@@ -9,6 +9,7 @@
16 #include "common/ceph_mutex.h"
17 #include "include/types.h"
18 #include "global/signal_handler.h"
19+#include <atomic>
20 #include <iostream>
21 #include <boost/accumulators/accumulators.hpp>
22 #include <boost/accumulators/statistics/stats.hpp>
23--
242.27.0
25
diff --git a/recipes-extended/ceph/ceph/0001-cmake-add-support-for-python3.9.patch b/recipes-extended/ceph/ceph/0001-cmake-add-support-for-python3.10.patch
index d9116c4f..94c4b8a6 100644
--- a/recipes-extended/ceph/ceph/0001-cmake-add-support-for-python3.9.patch
+++ b/recipes-extended/ceph/ceph/0001-cmake-add-support-for-python3.10.patch
@@ -1,13 +1,17 @@
1From 1060f2e4362ebd6db23870d442dcd158d219ee92 Mon Sep 17 00:00:00 2001 1From 1060f2e4362ebd6db23870d442dcd158d219ee92 Mon Sep 17 00:00:00 2001
2From: Yanfei Xu <yanfei.xu@windriver.com> 2From: Yanfei Xu <yanfei.xu@windriver.com>
3Date: Tue, 10 Nov 2020 17:17:30 +0800 3Date: Tue, 10 Nov 2020 17:17:30 +0800
4Subject: [PATCH] cmake: add support for python3.9 4Subject: [PATCH] cmake: add support for python 3.9 and 3.10
5 5
6add support for python3.9. 6add support for python3.9.
7 7
8Upstream-Status: Pending
9
10Signed-off-by: Yanfei Xu <yanfei.xu@windriver.com> 8Signed-off-by: Yanfei Xu <yanfei.xu@windriver.com>
9
10Add support for python 3.10.
11
12Upstream-Status: Submitted [https://github.com/ceph/ceph/pull/43630]
13
14Signed-off-by: Kai Kang <kai.kang@windriver.com>
11--- 15---
12 cmake/modules/FindPython/Support.cmake | 2 +- 16 cmake/modules/FindPython/Support.cmake | 2 +-
13 1 file changed, 1 insertion(+), 1 deletion(-) 17 1 file changed, 1 insertion(+), 1 deletion(-)
@@ -21,7 +25,7 @@ index 6584699b79..c05bbe3306 100644
21 endif() 25 endif()
22 if (_${_PYTHON_PREFIX}_REQUIRED_VERSION_MAJOR EQUAL 3) 26 if (_${_PYTHON_PREFIX}_REQUIRED_VERSION_MAJOR EQUAL 3)
23- set(_${_PYTHON_PREFIX}_VERSIONS 3.8 3.7 3.6 3.5 3.4 3.3 3.2 3.1 3.0) 27- set(_${_PYTHON_PREFIX}_VERSIONS 3.8 3.7 3.6 3.5 3.4 3.3 3.2 3.1 3.0)
24+ set(_${_PYTHON_PREFIX}_VERSIONS 3.9 3.8 3.7 3.6 3.5 3.4 3.3 3.2 3.1 3.0) 28+ set(_${_PYTHON_PREFIX}_VERSIONS 3.10 3.9 3.8 3.7 3.6 3.5 3.4 3.3 3.2 3.1 3.0)
25 elseif (_${_PYTHON_PREFIX}_REQUIRED_VERSION_MAJOR EQUAL 2) 29 elseif (_${_PYTHON_PREFIX}_REQUIRED_VERSION_MAJOR EQUAL 2)
26 set(_${_PYTHON_PREFIX}_VERSIONS 2.7 2.6 2.5 2.4 2.3 2.2 2.1 2.0) 30 set(_${_PYTHON_PREFIX}_VERSIONS 2.7 2.6 2.5 2.4 2.3 2.2 2.1 2.0)
27 else() 31 else()
diff --git a/recipes-extended/ceph/ceph_15.2.12.bb b/recipes-extended/ceph/ceph_15.2.15.bb
index 693b5259..0d9bae02 100644
--- a/recipes-extended/ceph/ceph_15.2.12.bb
+++ b/recipes-extended/ceph/ceph_15.2.15.bb
@@ -12,15 +12,11 @@ SRC_URI = "http://download.ceph.com/tarballs/ceph-${PV}.tar.gz \
12 file://0001-ceph-fix-build-errors-for-cross-compile.patch \ 12 file://0001-ceph-fix-build-errors-for-cross-compile.patch \
13 file://0001-fix-host-library-paths-were-used.patch \ 13 file://0001-fix-host-library-paths-were-used.patch \
14 file://ceph.conf \ 14 file://ceph.conf \
15 file://0001-add-missing-include-for-atomic-bool.patch \ 15 file://0001-cmake-add-support-for-python3.10.patch \
16 file://0001-cmake-add-support-for-python3.9.patch \
17 file://0001-SnappyCompressor.h-fix-snappy-compiler-error.patch \ 16 file://0001-SnappyCompressor.h-fix-snappy-compiler-error.patch \
18" 17"
19 18
20SRC_URI[sha1sum] = "9c76b298e1e659b9c5501003ac77fb28aab7823d" 19SRC_URI[sha256sum] = "5dccdaff2ebe18d435b32bfc06f8b5f474bf6ac0432a6a07d144b7c56700d0bf"
21SRC_URI[sha256sum] = "8710f6700de83765138df8eb4fc7a5e7c66104dd838033e0827a1850f250ac85"
22SRC_URI[sha384sum] = "2a2f177e5b68f6f5d13b253a8d4daba9e956b4a79a40a4775aee288b60c612fe13b417d6baf77944c32b1181b2136f68"
23SRC_URI[sha512sum] = "08266a2e9a7ca5a37e03f340873571fd012c630dd898a87241cd97c29760b2bf41fe64c8883e7b08e0f83c26245072cd26e69ecb1db02378d1ec38335ba1cd0f"
24 20
25DEPENDS = "boost bzip2 curl expat gperf-native \ 21DEPENDS = "boost bzip2 curl expat gperf-native \
26 keyutils libaio libibverbs lz4 \ 22 keyutils libaio libibverbs lz4 \
@@ -133,6 +129,7 @@ RDEPENDS:${PN} += "\
133 python3-modules \ 129 python3-modules \
134 python3-prettytable \ 130 python3-prettytable \
135 ${PN}-python \ 131 ${PN}-python \
132 gawk \
136" 133"
137COMPATIBLE_HOST = "(x86_64).*" 134COMPATIBLE_HOST = "(x86_64).*"
138PACKAGES += " \ 135PACKAGES += " \