summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2021-10-29 11:29:27 -0400
committerBruce Ashfield <bruce.ashfield@gmail.com>2021-11-03 09:48:00 -0400
commit369367c0206b009f01d917ac38881c05e1aaf8f4 (patch)
treedb9239bf9668a4a8991934245e04a9176cf25fae
parentbaf9e1a06f116c12af46a4400edfc1aa10d3fc8b (diff)
downloadmeta-virtualization-369367c0206b009f01d917ac38881c05e1aaf8f4.tar.gz
lopper: update to master-next
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-kernel/lopper/lopper.bb16
1 files changed, 8 insertions, 8 deletions
diff --git a/recipes-kernel/lopper/lopper.bb b/recipes-kernel/lopper/lopper.bb
index 3db55d12..f36b898c 100644
--- a/recipes-kernel/lopper/lopper.bb
+++ b/recipes-kernel/lopper/lopper.bb
@@ -3,8 +3,8 @@ DESCRIPTION = "Tool for manipulation of system device tree files"
3LICENSE = "BSD-3-Clause" 3LICENSE = "BSD-3-Clause"
4SECTION = "bootloader" 4SECTION = "bootloader"
5 5
6SRC_URI = "git://github.com/devicetree-org/lopper.git;branch=master;protocol=https" 6SRC_URI = "git://github.com/devicetree-org/lopper.git;branch=master-next;protocol=https"
7SRCREV = "0c23e51d585608ab04009ccf3499f168e2f4d478" 7SRCREV = "3e6aa522d2469ba7563fc6691802cf4aae3d2fd7"
8S = "${WORKDIR}/git" 8S = "${WORKDIR}/git"
9 9
10LIC_FILES_CHKSUM = "file://LICENSE.md;md5=8e5f5f691f01c9fdfa7a7f2d535be619" 10LIC_FILES_CHKSUM = "file://LICENSE.md;md5=8e5f5f691f01c9fdfa7a7f2d535be619"
@@ -19,16 +19,16 @@ do_install() {
19 install -d "${D}/${bindir}" 19 install -d "${D}/${bindir}"
20 install -d "${D}/${datadir}/${BPN}" 20 install -d "${D}/${datadir}/${BPN}"
21 21
22 install -m 0644 "${S}/README" "${D}/${datadir}/${BPN}" 22 install -m 0644 "${S}/README.md" "${D}/${datadir}/${BPN}"
23 install -m 0644 "${S}/README-architecture.txt" "${D}/${datadir}/${BPN}" 23 install -m 0644 "${S}/README-architecture.md" "${D}/${datadir}/${BPN}"
24 install -m 0644 "${S}/README.pydoc" "${D}/${datadir}/${BPN}" 24 install -m 0644 "${S}/README.pydoc" "${D}/${datadir}/${BPN}"
25 install -m 0644 "${S}/LICENSE.md" "${D}/${datadir}/${BPN}" 25 install -m 0644 "${S}/LICENSE.md" "${D}/${datadir}/${BPN}"
26 26
27 install -d "${D}/${datadir}/${BPN}/assists" 27 install -d "${D}/${datadir}/${BPN}/lopper/assists"
28 install -m 0644 "${S}/assists/"* "${D}/${datadir}/${BPN}/assists/" 28 cp -r "${S}/lopper/assists/"* "${D}/${datadir}/${BPN}/lopper/assists/"
29 29
30 install -d "${D}/${datadir}/${BPN}/lops" 30 install -d "${D}/${datadir}/${BPN}/lopper/lops"
31 install -m 0644 "${S}/lops/"* "${D}/${datadir}/${BPN}/lops/" 31 install -m 0644 "${S}/lopper/lops/"* "${D}/${datadir}/${BPN}/lopper/lops/"
32 32
33 install -d "${D}/${datadir}/${BPN}/device-trees" 33 install -d "${D}/${datadir}/${BPN}/device-trees"
34 install -m 0644 "${S}/device-trees/"* "${D}/${datadir}/${BPN}/device-trees/" 34 install -m 0644 "${S}/device-trees/"* "${D}/${datadir}/${BPN}/device-trees/"