summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2021-09-17 08:26:59 -0400
committerBruce Ashfield <bruce.ashfield@gmail.com>2021-09-17 08:27:13 -0400
commit1fae6921b6be905e52a396974d55ac387f56a4ec (patch)
tree7474b2bb3c9c84de9207888709814192d8ce86a3
parent807506c777a45d805400ec6f47b45420e300c2e5 (diff)
downloadmeta-virtualization-1fae6921b6be905e52a396974d55ac387f56a4ec.tar.gz
Revert "ceph/libibverbs: replace libibverbs with rdma-core"
meta-cloud-services still has users of libibverbs, so we'll keep it around a bit longer. But this library has been replaced by rdma-core, and won't get more updates, so it should be considered depreciated and slated for removal. This reverts commit 513f05926a5bdcda033a5da6f76f4f0dddb9d41f.
-rw-r--r--recipes-extended/ceph/ceph_15.2.12.bb2
-rw-r--r--recipes-extended/libibverbs/libibverbs_1.2.1.bb34
2 files changed, 35 insertions, 1 deletions
diff --git a/recipes-extended/ceph/ceph_15.2.12.bb b/recipes-extended/ceph/ceph_15.2.12.bb
index 6f6fb723..6636d7a4 100644
--- a/recipes-extended/ceph/ceph_15.2.12.bb
+++ b/recipes-extended/ceph/ceph_15.2.12.bb
@@ -23,7 +23,7 @@ SRC_URI[sha384sum] = "2a2f177e5b68f6f5d13b253a8d4daba9e956b4a79a40a4775aee288b60
23SRC_URI[sha512sum] = "08266a2e9a7ca5a37e03f340873571fd012c630dd898a87241cd97c29760b2bf41fe64c8883e7b08e0f83c26245072cd26e69ecb1db02378d1ec38335ba1cd0f" 23SRC_URI[sha512sum] = "08266a2e9a7ca5a37e03f340873571fd012c630dd898a87241cd97c29760b2bf41fe64c8883e7b08e0f83c26245072cd26e69ecb1db02378d1ec38335ba1cd0f"
24 24
25DEPENDS = "boost bzip2 curl expat gperf-native \ 25DEPENDS = "boost bzip2 curl expat gperf-native \
26 keyutils libaio rdma-core lz4 \ 26 keyutils libaio libibverbs lz4 \
27 nspr nss \ 27 nspr nss \
28 oath openldap openssl \ 28 oath openldap openssl \
29 python3 python3-cython-native rabbitmq-c rocksdb snappy udev \ 29 python3 python3-cython-native rabbitmq-c rocksdb snappy udev \
diff --git a/recipes-extended/libibverbs/libibverbs_1.2.1.bb b/recipes-extended/libibverbs/libibverbs_1.2.1.bb
new file mode 100644
index 00000000..90c424ec
--- /dev/null
+++ b/recipes-extended/libibverbs/libibverbs_1.2.1.bb
@@ -0,0 +1,34 @@
1SUMMARY = "Support InfiniBand verbs"
2DESCRIPTION = "Libibverbs is a library that allows userspace processes to use InfiniBand/RDMA 'verbs' directly."
3HOMEPAGE = "http://www.openfabrics.org/downloads/verbs/"
4SECTION = "libs/devel"
5
6LICENSE = "BSD"
7LIC_FILES_CHKSUM = "file://COPYING;md5=7c557f27dd795ba77cc419dddc656b51"
8
9# Official repo is at git://git.kernel.org/pub/scm/libs/infiniband/libibverbs.git
10SRC_URI = "https://www.openfabrics.org/downloads/verbs/${BPN}-${PV}.tar.gz"
11
12SRC_URI[md5sum] = "1544ebb89d861ce84057ab43dfcd22a0"
13SRC_URI[sha256sum] = "c352a7f24e9a9d30ea74faa35d1b721d78d770506a0c03732e3132b7c85ac330"
14
15inherit autotools
16
17DEPENDS = "libnl pkgconfig-native"
18PACKAGES += "${PN}-utils"
19FILES:${PN} = "${sysconfdir} ${libdir}/*.so.*"
20FILES:${PN}-utils = "${bindir}"
21
22PACKAGECONFIG ??= ""
23PACKAGECONFIG[valgrind] = "--with-valgrind,--without-valgrind,valgrind,"
24
25do_install:append() {
26 mkdir -p ${D}${sysconfdir}/libibverbs.d
27 rm -f ${D}${libdir}/libibverbs.la
28}
29
30PROVIDES = "virtual/libibverbs"
31RPROVIDES:${PN} = "virtual-libibverbs"
32
33COMPATIBLE_HOST:mipsarch = "none"
34COMPATIBLE_HOST:arm = "none"