summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLei Yang <lei.yang@windriver.com>2013-01-23 11:28:11 +0800
committerDavid Nyström <david.nystrom@enea.com>2013-01-23 10:16:56 +0100
commit28067e1012798e46cbe4fbf8add8586f5ac08d1d (patch)
tree3161377dd24a300c26be3aade7b71fb2ac21cf80
parente00b22326246fa9dc6bc6b8923fc2d8accdee8d3 (diff)
downloadmeta-virtualization-28067e1012798e46cbe4fbf8add8586f5ac08d1d.tar.gz
multipath-tools: add multipath-tools recipe
This package provides: - multipath: scans the system for multipathed devices, assembles - multipathd: waits for maps events then execs multipath - kpartx: maps linear devmaps to device partitions, which makes multipath maps partionable ...... Now,It can be used for kvm disk img partion mounting for me. Signed-off-by: Lei Yang <lei.yang@windriver.com>
-rw-r--r--recipes-extended/multipath-tools/multipath-tools_git.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/recipes-extended/multipath-tools/multipath-tools_git.bb b/recipes-extended/multipath-tools/multipath-tools_git.bb
new file mode 100644
index 00000000..633b9f2f
--- /dev/null
+++ b/recipes-extended/multipath-tools/multipath-tools_git.bb
@@ -0,0 +1,46 @@
1SUMMARY = "Tools to Manage Multipathed Devices with the device-mapper"
2DESCRIPTION = "This package provides the tools to manage multipathed devices by \
3instructing the device-mapper multipath module what to do"
4
5HOMEPAGE = "http://christophe.varoqui.free.fr/"
6DEPENDS = "readline libaio lvm2"
7LICENSE = "GPLv2"
8
9LIC_FILES_CHKSUM = "file://COPYING;md5=7be2873b6270e45abacc503abbe2aa3d"
10S="${WORKDIR}/git"
11
12
13SRC_URI = "git://git.opensvc.com/multipath-tools/.git;protocol=http"
14
15SRCREV = "d3683ab18b386e9b3b54b59a122c689e9ebdf5cf"
16PV = "0.4.9+gitr${SRCPV}"
17
18inherit autotools
19
20EXTRA_OEMAKE="LIB=${libdir} exec_prefix=${exec_prefix} libdir=${libdir}"
21
22PACKAGES =+ "libmpathpersist mpathpersist kpartx libmultipath multipath multipathd libmultipath-dev libmpathpersist-dev"
23
24
25RDEPENDS_${PN} += "libmpathpersist mpathpersist kpartx libmultipath multipath multipathd udev"
26
27do_install_append () {
28 ln -sf libmpathpersist.so.0 ${D}${libdir}/libmpathpersist.so
29 ln -sf libmultipath.so.0 ${D}${libdir}/libmultipath.so
30}
31
32ALLOW_EMPTY_${PN} = "1"
33FILES_${PN} = ""
34
35FILES_libmpathpersist = "${libdir}/libmpathpersist*.so.0"
36FILES_mpathpersist = "${sbindir}/mpathpersist"
37FILES_kpartx = "${sbindir}/kpartx ${base_libdir}/udev/"
38FILES_libmultipath = "${libdir}/libcheck*.so ${libdir}/libpri*.so ${libdir}/libmultipath*.so.0"
39FILES_multipath = "${sbindir}/multipath ${sysconfdir}"
40FILES_multipathd = "${sbindir}/multipathd ${base_libdir}"
41
42#put the symbol link lib in -dev
43FILES_libmultipath-dev = "${libdir}/libmultipath*.so"
44FILES_libmpathpersist-dev = "${libdir}/libmpathpersist*.so"
45
46