summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2013-06-27 15:23:34 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2013-06-28 14:05:48 -0400
commitc4432c79f96394f0a874436fc769f093c6f3bcd5 (patch)
tree711436ddbd5b0dd1db11b713bd7fc59adc959fea
parentb6dc9613cda67df165e6d0a058e82ccb33282a1d (diff)
downloadmeta-virtualization-c4432c79f96394f0a874436fc769f093c6f3bcd5.tar.gz
libvirt: switch to use volatile system for directory creation in /var/run
libvirt relies on its Makefile's install rules to create several directories in /var/run/libvirt. The use of ALLOW_EMPTY_ allows these to be included in the RPM, however, they are cleared out at boot by the volatile system. This causes issues since the libvirt runtime does not check for the existence of these directories prior to attempting to create files in them, resulting in errors. Here we add to the volatiles allowing the required directories to be created at boot or when the volatiles are updated. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-extended/libvirt/libvirt_1.0.3.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-extended/libvirt/libvirt_1.0.3.bb b/recipes-extended/libvirt/libvirt_1.0.3.bb
index 479ce7e1..768ccc8d 100644
--- a/recipes-extended/libvirt/libvirt_1.0.3.bb
+++ b/recipes-extended/libvirt/libvirt_1.0.3.bb
@@ -150,4 +150,25 @@ do_install_append() {
150 # This will wind up in the libvirtd package, but will NOT be invoked by default. 150 # This will wind up in the libvirtd package, but will NOT be invoked by default.
151 # 151 #
152 mv ${D}/${libexecdir}/libvirt-guests.sh ${D}/${sysconfdir}/init.d 152 mv ${D}/${libexecdir}/libvirt-guests.sh ${D}/${sysconfdir}/init.d
153
154 # The /var/run/libvirt directories created by the Makefile
155 # are wiped out in volatile, we need to create these at boot.
156 rm -rf ${D}${localstatedir}/run
157 install -d ${D}${sysconfdir}/default/volatiles
158 echo "d root root 0755 ${localstatedir}/run/libvirt none" \
159 > ${D}${sysconfdir}/default/volatiles/99_libvirt
160 echo "d root root 0755 ${localstatedir}/run/libvirt/lockd none" \
161 >> ${D}${sysconfdir}/default/volatiles/99_libvirt
162 echo "d root root 0755 ${localstatedir}/run/libvirt/lxc none" \
163 >> ${D}${sysconfdir}/default/volatiles/99_libvirt
164 echo "d root root 0755 ${localstatedir}/run/libvirt/network none" \
165 >> ${D}${sysconfdir}/default/volatiles/99_libvirt
166 echo "d root root 0755 ${localstatedir}/run/libvirt/qemu none" \
167 >> ${D}${sysconfdir}/default/volatiles/99_libvirt
168}
169
170pkg_postinst_libvirt() {
171 if [ -z "$D" ] && [ -e /etc/init.d/populate-volatile.sh ] ; then
172 /etc/init.d/populate-volatile.sh update
173 fi
153} 174}