summaryrefslogtreecommitdiffstats
path: root/recipes-test/images/secondary-image.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-test/images/secondary-image.bb')
-rw-r--r--recipes-test/images/secondary-image.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/recipes-test/images/secondary-image.bb b/recipes-test/images/secondary-image.bb
index 9adbdc5..75deb5a 100644
--- a/recipes-test/images/secondary-image.bb
+++ b/recipes-test/images/secondary-image.bb
@@ -1,9 +1,22 @@
1include recipes-core/images/core-image-minimal.bb 1include recipes-core/images/core-image-minimal.bb
2 2
3export SOTA_SECONDARY_HARDWARE_ID
4export SOTA_HARDWARE_ID
5
3SUMMARY = "A minimal Uptane Secondary image running aktualizr-secondary" 6SUMMARY = "A minimal Uptane Secondary image running aktualizr-secondary"
4 7
5LICENSE = "MIT" 8LICENSE = "MIT"
6 9
10IMAGE_TYPEDEP_garagesign_append = " set_hardware_id "
11IMAGE_CMD_set_hardware_id() {
12 if [ -n "${SOTA_SECONDARY_HARDWARE_ID}" ]; then
13 SOTA_HARDWARE_ID="${SOTA_SECONDARY_HARDWARE_ID}"
14 fi
15}
16#python IMAGE_CMD_set_hardware_id() {
17# if d.getVar("SOTA_SECONDARY_HARDWARE_ID", True):
18# d.setVar("SOTA_HARDWARE_ID", d.getVar("SOTA_SECONDARY_HARDWARE_ID", True))
19#}
7 20
8# Remove default aktualizr primary, and the provisioning configuration (which 21# Remove default aktualizr primary, and the provisioning configuration (which
9# RDEPENDS on aktualizr) 22# RDEPENDS on aktualizr)
@@ -19,6 +32,7 @@ IMAGE_INSTALL_remove = " \
19 32
20IMAGE_INSTALL_append = " \ 33IMAGE_INSTALL_append = " \
21 aktualizr-secondary \ 34 aktualizr-secondary \
35 aktualizr-secondary-conf \
22 secondary-network-config \ 36 secondary-network-config \
23 " 37 "
24 38