summaryrefslogtreecommitdiffstats
path: root/recipes-test/demo-network-config
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-test/demo-network-config')
-rw-r--r--recipes-test/demo-network-config/files/25-dhcp-server.network4
-rw-r--r--recipes-test/demo-network-config/primary-network-config.bb2
-rw-r--r--recipes-test/demo-network-config/secondary-network-config.bb4
3 files changed, 5 insertions, 5 deletions
diff --git a/recipes-test/demo-network-config/files/25-dhcp-server.network b/recipes-test/demo-network-config/files/25-dhcp-server.network
index 4766f9a..03bb302 100644
--- a/recipes-test/demo-network-config/files/25-dhcp-server.network
+++ b/recipes-test/demo-network-config/files/25-dhcp-server.network
@@ -4,9 +4,9 @@ Name=enp0s4
4[Network] 4[Network]
5Description=Private internal network between aktualizr Primary and Secondary nodes 5Description=Private internal network between aktualizr Primary and Secondary nodes
6DHCPServer=yes 6DHCPServer=yes
7Address=10.0.3.1/24 7Address=192.168.254.1/24
8IPForward=yes 8IPForward=yes
9IPMasquerade=yes 9IPMasquerade=yes
10 10
11[DHCPServer] 11[DHCPServer]
12PoolOffset=10 \ No newline at end of file 12PoolOffset=10
diff --git a/recipes-test/demo-network-config/primary-network-config.bb b/recipes-test/demo-network-config/primary-network-config.bb
index 544a5ec..7ee873f 100644
--- a/recipes-test/demo-network-config/primary-network-config.bb
+++ b/recipes-test/demo-network-config/primary-network-config.bb
@@ -15,7 +15,7 @@ do_install() {
15 install -m 0644 ${WORKDIR}/27-dhcp-client-external.network ${D}${libdir}/systemd/network/ 15 install -m 0644 ${WORKDIR}/27-dhcp-client-external.network ${D}${libdir}/systemd/network/
16} 16}
17 17
18PRIMARY_IP ?= "10.0.3.1" 18PRIMARY_IP ?= "192.168.254.1"
19 19
20IP_ADDR = "${PRIMARY_IP}" 20IP_ADDR = "${PRIMARY_IP}"
21CONF_TYPE ?= "${@ 'multihomed' if d.getVar('MACHINE') == 'raspberrypi3' and d.getVar('RPI_WIFI_ENABLE') != '1' else 'static'}" 21CONF_TYPE ?= "${@ 'multihomed' if d.getVar('MACHINE') == 'raspberrypi3' and d.getVar('RPI_WIFI_ENABLE') != '1' else 'static'}"
diff --git a/recipes-test/demo-network-config/secondary-network-config.bb b/recipes-test/demo-network-config/secondary-network-config.bb
index ca83d53..b268cd3 100644
--- a/recipes-test/demo-network-config/secondary-network-config.bb
+++ b/recipes-test/demo-network-config/secondary-network-config.bb
@@ -19,9 +19,9 @@ do_install() {
19 install -m 0644 ${WORKDIR}/27-dhcp-client-external.network ${D}${libdir}/systemd/network/ 19 install -m 0644 ${WORKDIR}/27-dhcp-client-external.network ${D}${libdir}/systemd/network/
20} 20}
21 21
22SECONDARY_IP ?= "10.0.3.2" 22SECONDARY_IP ?= "192.168.254.2"
23IP_ADDR = "${SECONDARY_IP}" 23IP_ADDR = "${SECONDARY_IP}"
24CONF_TYPE = "static" 24CONF_TYPE ?= "${@ 'multihomed' if d.getVar('MACHINE') == 'raspberrypi3' and d.getVar('RPI_WIFI_ENABLE') != '1' else 'static'}"
25 25
26require network-config.inc 26require network-config.inc
27 27