summaryrefslogtreecommitdiffstats
path: root/recipes-test/demo-network-config/secondary-network-config.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-test/demo-network-config/secondary-network-config.bb')
-rw-r--r--recipes-test/demo-network-config/secondary-network-config.bb13
1 files changed, 10 insertions, 3 deletions
diff --git a/recipes-test/demo-network-config/secondary-network-config.bb b/recipes-test/demo-network-config/secondary-network-config.bb
index 9091c65..6473e05 100644
--- a/recipes-test/demo-network-config/secondary-network-config.bb
+++ b/recipes-test/demo-network-config/secondary-network-config.bb
@@ -3,18 +3,25 @@ LICENSE = "CLOSED"
3 3
4inherit allarch 4inherit allarch
5 5
6# TODO: It configures the 'user' interface in NAT mode and provides an access to public Inet via it
7# which is not desired for Secondary. It cannot be just removed since we get SSH access to Secondary
8# VM via this interface. So, the task is to configure the interface in such way that it does provide access
9# via SSH from a host machine and forbids an access to Inet
6SRC_URI = "\ 10SRC_URI = "\
7 file://26-dhcp-client.network \
8 file://27-dhcp-client-external.network \ 11 file://27-dhcp-client-external.network \
9 " 12 "
10 13
11
12FILES_${PN} = "/usr/lib/systemd/network" 14FILES_${PN} = "/usr/lib/systemd/network"
13 15
14PR = "1" 16PR = "1"
15 17
16do_install() { 18do_install() {
17 install -d ${D}/usr/lib/systemd/network 19 install -d ${D}/usr/lib/systemd/network
18 install -m 0644 ${WORKDIR}/26-dhcp-client.network ${D}/usr/lib/systemd/network/
19 install -m 0644 ${WORKDIR}/27-dhcp-client-external.network ${D}/usr/lib/systemd/network/ 20 install -m 0644 ${WORKDIR}/27-dhcp-client-external.network ${D}/usr/lib/systemd/network/
20} 21}
22
23SECONDARY_NETWORK_IP_ADDR ?= "10.0.3.2"
24
25require static-network-config.inc
26
27# vim:set ts=4 sw=4 sts=4 expandtab: