summaryrefslogtreecommitdiffstats
path: root/recipes-test/demo-network-config/primary-network-config.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-test/demo-network-config/primary-network-config.bb')
-rw-r--r--recipes-test/demo-network-config/primary-network-config.bb13
1 files changed, 10 insertions, 3 deletions
diff --git a/recipes-test/demo-network-config/primary-network-config.bb b/recipes-test/demo-network-config/primary-network-config.bb
index 78678a2..ce19f07 100644
--- a/recipes-test/demo-network-config/primary-network-config.bb
+++ b/recipes-test/demo-network-config/primary-network-config.bb
@@ -3,8 +3,9 @@ LICENSE = "CLOSED"
3 3
4inherit allarch 4inherit allarch
5 5
6SRC_URI = "file://25-dhcp-server.network" 6SRC_URI = "\
7 7 file://27-dhcp-client-external.network \
8 "
8 9
9FILES_${PN} = "/usr/lib/systemd/network" 10FILES_${PN} = "/usr/lib/systemd/network"
10 11
@@ -12,5 +13,11 @@ PR = "1"
12 13
13do_install() { 14do_install() {
14 install -d ${D}/usr/lib/systemd/network 15 install -d ${D}/usr/lib/systemd/network
15 install -m 0644 ${WORKDIR}/25-dhcp-server.network ${D}/usr/lib/systemd/network/ 16 install -m 0644 ${WORKDIR}/27-dhcp-client-external.network ${D}/usr/lib/systemd/network/
16} 17}
18
19SECONDARY_NETWORK_IP_ADDR ?= "10.0.3.1"
20
21require static-network-config.inc
22
23# vim:set ts=4 sw=4 sts=4 expandtab: