summaryrefslogtreecommitdiffstats
path: root/recipes-support/softhsm/softhsm_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-support/softhsm/softhsm_git.bb')
-rw-r--r--recipes-support/softhsm/softhsm_git.bb31
1 files changed, 15 insertions, 16 deletions
diff --git a/recipes-support/softhsm/softhsm_git.bb b/recipes-support/softhsm/softhsm_git.bb
index c26903d..4dcfe7d 100644
--- a/recipes-support/softhsm/softhsm_git.bb
+++ b/recipes-support/softhsm/softhsm_git.bb
@@ -1,27 +1,26 @@
1SUMMARY = "HSM emulator" 1SUMMARY = "HSM emulator"
2LICENSE = "BSD" 2HOMEPAGE = "https://www.opendnssec.org/softhsm/"
3LICENSE = "BSD-2-Clause & ISC"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=ef3f77a3507c3d91e75b9f2bdaee4210" 4LIC_FILES_CHKSUM = "file://LICENSE;md5=ef3f77a3507c3d91e75b9f2bdaee4210"
4 5
5inherit autotools-brokensep 6DEPENDS = "openssl"
6 7
8SRC_URI = "git://github.com/opendnssec/SoftHSMv2.git;branch=master"
9SRCREV = "369df0383d101bc8952692c2a368ac8bc887d1b4"
7 10
8SRC_URI = "git://github.com/opendnssec/SoftHSMv2.git;branch=master \ 11PV = "2.5.0"
9 file://0001-Cross-compilation-tweaks.patch"
10SRCREV="1f7498c0c65b1b1ad5e1bdbd87e9d4b100705745"
11 12
12S = "${WORKDIR}/git" 13S = "${WORKDIR}/git"
13 14
14DEPENDS += " openssl" 15inherit autotools pkgconfig
15 16
16EXTRA_OECONF = "--disable-gost --with-openssl=${STAGING_LIBDIR}/.." 17# EdDSA requires OpenSSL >= 1.1.1
18EXTRA_OECONF = "--enable-eddsa --disable-gost"
17 19
18do_configure() { 20do_configure_prepend() {
19 unset docdir 21 (
20 sh ./autogen.sh 22 cd ${S}
21 oe_runconf 23 unset docdir
24 sh ./autogen.sh
25 )
22} 26}
23
24FILES_${PN} = "${bindir} \
25 ${libdir}/softhsm \
26 ${sysconfdir} \
27 ${localstatedir}/lib/softhsm "