summaryrefslogtreecommitdiffstats
path: root/recipes-support/softhsm-testtoken/softhsm-testtoken.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-support/softhsm-testtoken/softhsm-testtoken.bb')
-rw-r--r--recipes-support/softhsm-testtoken/softhsm-testtoken.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-support/softhsm-testtoken/softhsm-testtoken.bb b/recipes-support/softhsm-testtoken/softhsm-testtoken.bb
new file mode 100644
index 0000000..029fe1c
--- /dev/null
+++ b/recipes-support/softhsm-testtoken/softhsm-testtoken.bb
@@ -0,0 +1,25 @@
1SUMMARY = "Mock smartcard for aktualizr"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
4
5inherit systemd
6
7RDEPENDS_${PN} = "softhsm libp11"
8DEPENDS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', ' systemd', '', d)}"
9
10
11SRC_URI = "file://createtoken.service \
12 file://createtoken.sh"
13
14SYSTEMD_SERVICE_${PN} = "createtoken.service"
15
16do_install() {
17 install -d ${D}${systemd_unitdir}/system
18 install -m 0644 ${WORKDIR}/createtoken.service ${D}${systemd_unitdir}/system/createtoken.service
19 install -d ${D}${bindir}
20 install -m 0744 ${WORKDIR}/createtoken.sh ${D}${bindir}/createtoken.sh
21}
22
23FILES_${PN} = "${bindir}/createtoken.sh \
24 ${systemd_unitdir}/system/createtoken.service"
25