summaryrefslogtreecommitdiffstats
path: root/recipes-support/softhsm-testtoken/softhsm-testtoken.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-support/softhsm-testtoken/softhsm-testtoken.bb')
-rw-r--r--recipes-support/softhsm-testtoken/softhsm-testtoken.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-support/softhsm-testtoken/softhsm-testtoken.bb b/recipes-support/softhsm-testtoken/softhsm-testtoken.bb
new file mode 100644
index 0000000..c5691db
--- /dev/null
+++ b/recipes-support/softhsm-testtoken/softhsm-testtoken.bb
@@ -0,0 +1,27 @@
1SUMMARY = "Mock smartcard for aktualizr"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690 \
4 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
5
6
7inherit systemd
8
9RDEPENDS_${PN} = "softhsm libp11"
10DEPENDS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', ' systemd', '', d)}"
11
12
13SRC_URI = "file://createtoken.service \
14 file://createtoken.sh"
15
16SYSTEMD_SERVICE_${PN} = "createtoken.service"
17
18do_install() {
19 install -d ${D}${systemd_unitdir}/system
20 install -m 0644 ${WORKDIR}/createtoken.service ${D}${systemd_unitdir}/system/createtoken.service
21 install -d ${D}${bindir}
22 install -m 0744 ${WORKDIR}/createtoken.sh ${D}${bindir}/createtoken.sh
23}
24
25FILES_${PN} = "${bindir}/createtoken.sh \
26 ${systemd_unitdir}/system/createtoken.service"
27