summaryrefslogtreecommitdiffstats
path: root/recipes-support/libp11/libp11_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-support/libp11/libp11_git.bb')
-rw-r--r--recipes-support/libp11/libp11_git.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/recipes-support/libp11/libp11_git.bb b/recipes-support/libp11/libp11_git.bb
new file mode 100644
index 0000000..bedcdc8
--- /dev/null
+++ b/recipes-support/libp11/libp11_git.bb
@@ -0,0 +1,40 @@
1SUMMARY = "Library for using PKCS"
2DESCRIPTION = "\
3Libp11 is a library implementing a small layer on top of PKCS \
4make using PKCS"
5HOMEPAGE = "http://www.opensc-project.org/libp11"
6SECTION = "Development/Libraries"
7LICENSE = "LGPLv2+"
8LIC_FILES_CHKSUM = "file://COPYING;md5=fad9b3332be894bab9bc501572864b29"
9DEPENDS = "libtool openssl"
10RDEPENDS_${PN} += " opensc"
11
12SRC_URI = "git://github.com/OpenSC/libp11.git"
13SRCREV = "57ca68ff67efa08e3be1f26dec6d23bf5bb977f2"
14
15PV = "0.4.9+git${SRCPV}"
16
17S = "${WORKDIR}/git"
18
19inherit autotools pkgconfig
20
21# Currently, Makefile dependencies are incorrectly defined which causes build errors
22# if the number of jobs is high
23# See https://github.com/OpenSC/libp11/issues/94
24PARALLEL_MAKE = ""
25EXTRA_OECONF = "--disable-static"
26
27do_install_append () {
28 rm -rf ${D}${libdir}/*.la
29 rm -rf ${D}${docdir}/${BPN}
30}
31
32FILES_${PN} = "${libdir}/engines*/pkcs11.so \
33 ${libdir}/engines*/libpkcs11${SOLIBS} \
34 ${libdir}/libp11${SOLIBS}"
35
36FILES_${PN}-dev = " \
37 ${libdir}/engines*/libpkcs11${SOLIBSDEV} \
38 ${libdir}/libp11${SOLIBSDEV} \
39 ${libdir}/pkgconfig/libp11.pc \
40 /usr/include"