diff options
Diffstat (limited to 'recipes-sota')
-rwxr-xr-x | recipes-sota/aktualizr/aktualizr_git.bb | 3 | ||||
-rw-r--r-- | recipes-sota/config/aktualizr-auto-reboot.bb | 21 | ||||
-rw-r--r-- | recipes-sota/config/files/35-enable-auto-reboot.toml | 2 |
3 files changed, 25 insertions, 1 deletions
diff --git a/recipes-sota/aktualizr/aktualizr_git.bb b/recipes-sota/aktualizr/aktualizr_git.bb index 3b48e58..9dd90e8 100755 --- a/recipes-sota/aktualizr/aktualizr_git.bb +++ b/recipes-sota/aktualizr/aktualizr_git.bb | |||
@@ -23,7 +23,8 @@ SRC_URI = " \ | |||
23 | file://aktualizr-serialcan.service \ | 23 | file://aktualizr-serialcan.service \ |
24 | " | 24 | " |
25 | 25 | ||
26 | SRCREV = "2aa9d93ccea09ec327789eecf858de561ef632da" | 26 | |
27 | SRCREV = "c2da7b5dfe34ebe3482042dd461543da291c43bd" | ||
27 | BRANCH ?= "master" | 28 | BRANCH ?= "master" |
28 | 29 | ||
29 | S = "${WORKDIR}/git" | 30 | S = "${WORKDIR}/git" |
diff --git a/recipes-sota/config/aktualizr-auto-reboot.bb b/recipes-sota/config/aktualizr-auto-reboot.bb new file mode 100644 index 0000000..1317fd4 --- /dev/null +++ b/recipes-sota/config/aktualizr-auto-reboot.bb | |||
@@ -0,0 +1,21 @@ | |||
1 | SUMMARY = "Enable auto reboot to apply updates" | ||
2 | DESCRIPTION = "Configures aktualizr to auto reboot just after new updates installation in order to apply them" | ||
3 | HOMEPAGE = "https://github.com/advancedtelematic/aktualizr" | ||
4 | SECTION = "base" | ||
5 | LICENSE = "MPL-2.0" | ||
6 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7f619bab123dad" | ||
7 | |||
8 | SRC_URI = " \ | ||
9 | file://35-enable-auto-reboot.toml \ | ||
10 | " | ||
11 | |||
12 | do_install_append () { | ||
13 | install -m 0700 -d ${D}${libdir}/sota/conf.d | ||
14 | install -m 0644 ${WORKDIR}/35-enable-auto-reboot.toml ${D}${libdir}/sota/conf.d/35-enable-auto-reboot.toml | ||
15 | } | ||
16 | |||
17 | FILES_${PN} = " \ | ||
18 | ${libdir}/sota/conf.d/35-enable-auto-reboot.toml \ | ||
19 | " | ||
20 | |||
21 | # vim:set ts=4 sw=4 sts=4 expandtab: | ||
diff --git a/recipes-sota/config/files/35-enable-auto-reboot.toml b/recipes-sota/config/files/35-enable-auto-reboot.toml new file mode 100644 index 0000000..f83810e --- /dev/null +++ b/recipes-sota/config/files/35-enable-auto-reboot.toml | |||
@@ -0,0 +1,2 @@ | |||
1 | [uptane] | ||
2 | force_install_completion = true | ||