diff options
Diffstat (limited to 'recipes-sota/ostree')
-rwxr-xr-x | recipes-sota/ostree/files/touch-ostree | 21 | ||||
-rw-r--r-- | recipes-sota/ostree/ostree-booted_1.0.bb | 15 |
2 files changed, 36 insertions, 0 deletions
diff --git a/recipes-sota/ostree/files/touch-ostree b/recipes-sota/ostree/files/touch-ostree new file mode 100755 index 0000000..28cb672 --- /dev/null +++ b/recipes-sota/ostree/files/touch-ostree | |||
@@ -0,0 +1,21 @@ | |||
1 | #!/bin/sh | ||
2 | ### BEGIN INIT INFO | ||
3 | # Provides: touch-ostree | ||
4 | # Required-Start: $network $remote_fs | ||
5 | # Required-Stop: $network $remote_fs | ||
6 | # Default-Start: 2 3 4 5 | ||
7 | # Default-Stop: 0 1 6 | ||
8 | # Short-Description: Indicate OSTree boot | ||
9 | ### END INIT INFO | ||
10 | |||
11 | case "$1" in | ||
12 | start) | ||
13 | touch /run/ostree-booted | ||
14 | ;; | ||
15 | stop) | ||
16 | ;; | ||
17 | *) | ||
18 | echo "Usage: /etc/init.d/touch-ostree {start|stop}" | ||
19 | exit 1 | ||
20 | ;; | ||
21 | esac | ||
diff --git a/recipes-sota/ostree/ostree-booted_1.0.bb b/recipes-sota/ostree/ostree-booted_1.0.bb new file mode 100644 index 0000000..d74cf24 --- /dev/null +++ b/recipes-sota/ostree/ostree-booted_1.0.bb | |||
@@ -0,0 +1,15 @@ | |||
1 | SUMMARY = "Indicate an OSTree boot" | ||
2 | DESCRIPTION = "Indicate an OSTree boot" | ||
3 | LICENSE = "MPL-2.0" | ||
4 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7f619bab123dad" | ||
5 | SRC_URI = "file://touch-ostree" | ||
6 | |||
7 | inherit allarch update-rc.d | ||
8 | |||
9 | INITSCRIPT_NAME = "touch-ostree" | ||
10 | INITSCRIPT_PARAMS = "start 8 2 3 4 5 . stop 20 0 1 6 ." | ||
11 | |||
12 | do_install() { | ||
13 | install -d ${D}${sysconfdir}/init.d | ||
14 | install -m 0755 ${WORKDIR}/touch-ostree ${D}${sysconfdir}/init.d/touch-ostree | ||
15 | } | ||