summaryrefslogtreecommitdiffstats
path: root/recipes-sota/ostree/ostree_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-sota/ostree/ostree_git.bb')
-rw-r--r--recipes-sota/ostree/ostree_git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-sota/ostree/ostree_git.bb b/recipes-sota/ostree/ostree_git.bb
new file mode 100644
index 0000000..9009685
--- /dev/null
+++ b/recipes-sota/ostree/ostree_git.bb
@@ -0,0 +1,25 @@
1SUMMARY = "Tool for managing bootable, immutable, versioned filesystem trees"
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
4
5SRC_URI = "gitsm://git.gnome.org/ostree.git;branch=master"
6SRCREV="${AUTOREV}"
7
8S = "${WORKDIR}/git"
9
10DEPENDS += "attr libarchive glib-2.0 pkgconfig gpgme libgsystem fuse libsoup-2.4"
11
12RDEPENDS_${PN} = "python libsystemd util-linux-libuuid util-linux-libblkid util-linux-libmount libcap liblzma"
13
14inherit autotools-brokensep
15
16EXTRA_OECONF = "--with-libarchive --disable-gtk-doc --disable-gtk-doc-html --disable-gtk-doc-pdf --disable-man"
17
18FILES_${PN} += "${libdir}/ostree/ ${libdir}/ostbuild"
19
20BBCLASSEXTEND = "native"
21
22do_configure() {
23 NOCONFIGURE=true ./autogen.sh
24 oe_runconf
25}