summaryrefslogtreecommitdiffstats
path: root/recipes-sota/ostree/ostree_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-sota/ostree/ostree_git.bb')
-rw-r--r--recipes-sota/ostree/ostree_git.bb14
1 files changed, 8 insertions, 6 deletions
diff --git a/recipes-sota/ostree/ostree_git.bb b/recipes-sota/ostree/ostree_git.bb
index 67b5047..5775dfa 100644
--- a/recipes-sota/ostree/ostree_git.bb
+++ b/recipes-sota/ostree/ostree_git.bb
@@ -8,13 +8,13 @@ INHERIT_remove_class-native = "systemd"
8 8
9SRC_URI = "gitsm://github.com/ostreedev/ostree.git;branch=master" 9SRC_URI = "gitsm://github.com/ostreedev/ostree.git;branch=master"
10 10
11SRCREV="37c07d2f1c90b12bcfba85a7d900f81a7c362eb4" 11SRCREV="6517a8a27a1386e7cb5482e7cb2919fe92721ccf"
12 12
13S = "${WORKDIR}/git" 13S = "${WORKDIR}/git"
14 14
15BBCLASSEXTEND = "native" 15BBCLASSEXTEND = "native"
16 16
17DEPENDS += "attr libarchive glib-2.0 pkgconfig gpgme libgsystem fuse libsoup-2.4 e2fsprogs" 17DEPENDS += "attr libarchive glib-2.0 pkgconfig gpgme libgsystem fuse libsoup-2.4 e2fsprogs gtk-doc-native"
18DEPENDS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', ' systemd', '', d)}" 18DEPENDS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', ' systemd', '', d)}"
19 19
20DEPENDS_remove_class-native = "systemd-native" 20DEPENDS_remove_class-native = "systemd-native"
@@ -27,12 +27,12 @@ EXTRA_OEMAKE = "CFLAGS='-g'"
27EXTRA_OECONF_append_class-native = " --enable-wrpseudo-compat" 27EXTRA_OECONF_append_class-native = " --enable-wrpseudo-compat"
28 28
29SYSTEMD_REQUIRED = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}" 29SYSTEMD_REQUIRED = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}"
30SYSTEMD_REQUIRED_class-native = "false" 30SYSTEMD_REQUIRED_class-native = ""
31 31
32SYSTEMD_SERVICE_${PN} = "ostree-prepare-root.service ostree-remount.service" 32SYSTEMD_SERVICE_${PN} = "ostree-prepare-root.service ostree-remount.service"
33SYSTEMD_SERVICE_${PN}_class-native = "" 33SYSTEMD_SERVICE_${PN}_class-native = ""
34 34
35PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}" 35PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}"
36PACKAGECONFIG_class-native = "" 36PACKAGECONFIG_class-native = ""
37PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/ --with-dracut" 37PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/ --with-dracut"
38 38
@@ -42,7 +42,8 @@ export STAGING_INCDIR
42export STAGING_LIBDIR 42export STAGING_LIBDIR
43 43
44do_configure() { 44do_configure() {
45 NOCONFIGURE=true ./autogen.sh 45 unset docdir
46 NOCONFIGURE=1 ./autogen.sh
46 oe_runconf 47 oe_runconf
47} 48}
48 49
@@ -54,7 +55,8 @@ do_compile_prepend() {
54export SYSTEMD_REQUIRED 55export SYSTEMD_REQUIRED
55 56
56do_install_append() { 57do_install_append() {
57 if [ "$SYSTEMD_REQUIRED" == "true" ]; then 58 if [ -n $SYSTEMD_REQUIRED ]; then
59 install -p -D ${S}/src/boot/ostree-prepare-root.service ${D}${systemd_unitdir}/system/ostree-prepare-root.service
58 install -p -D ${S}/src/boot/ostree-remount.service ${D}${systemd_unitdir}/system/ostree-remount.service 60 install -p -D ${S}/src/boot/ostree-remount.service ${D}${systemd_unitdir}/system/ostree-remount.service
59 fi 61 fi
60} 62}