summaryrefslogtreecommitdiffstats
path: root/recipes-sota/ostree/ostree_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-sota/ostree/ostree_git.bb')
-rw-r--r--recipes-sota/ostree/ostree_git.bb87
1 files changed, 35 insertions, 52 deletions
diff --git a/recipes-sota/ostree/ostree_git.bb b/recipes-sota/ostree/ostree_git.bb
index 8937e5e..6386910 100644
--- a/recipes-sota/ostree/ostree_git.bb
+++ b/recipes-sota/ostree/ostree_git.bb
@@ -1,89 +1,72 @@
1SUMMARY = "Tool for managing bootable, immutable, versioned filesystem trees" 1SUMMARY = "Tool for managing bootable, immutable, versioned filesystem trees"
2LICENSE = "GPLv2+" 2HOMEPAGE = "https://ostree.readthedocs.io/en/latest/"
3LICENSE = "LGPLv2+"
3LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2" 4LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
4 5
5inherit autotools-brokensep pkgconfig systemd gobject-introspection 6inherit autotools pkgconfig systemd bash-completion gobject-introspection
6 7
7INHERIT_remove_class-native = "systemd" 8INHERIT_remove_class-native = "systemd"
8 9
9SRC_URI = "gitsm://github.com/ostreedev/ostree.git;branch=master" 10SRC_URI = "gitsm://github.com/ostreedev/ostree.git;branch=master"
10 11
11SRCREV="3b09620c2738bce4ed45e099cf2e4c5df7671d39" 12SRCREV="3e96ec9811b5cfc5481f8b6b06c8d34d9a35408e"
12 13
13PV = "2017.3-31-g3b09620c" 14PV = "v2018.7"
14 15
15S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
16 17
17BBCLASSEXTEND = "native" 18BBCLASSEXTEND = "native"
18 19
19DEPENDS += "attr libarchive glib-2.0 pkgconfig gpgme libgsystem fuse libsoup-2.4 e2fsprogs gtk-doc-native curl xz" 20DEPENDS += "attr bison-native libarchive libcap glib-2.0 gpgme fuse e2fsprogs curl xz"
20DEPENDS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', ' systemd', '', d)}" 21DEPENDS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', ' systemd', '', d)}"
21DEPENDS_remove_class-native = "systemd-native" 22DEPENDS_remove_class-native = "systemd-native"
23RDEPENDS_${PN}-dracut = "bash"
22 24
23RDEPENDS_${PN} = "python util-linux-libuuid util-linux-libblkid util-linux-libmount libcap bash" 25CFLAGS_append = " -Wno-error=missing-prototypes"
24RDEPENDS_${PN}_remove_class-native = "python-native" 26EXTRA_OECONF = "--disable-gtk-doc --disable-man --with-smack --with-builtin-grub2-mkconfig --with-curl --without-soup"
25
26EXTRA_OECONF = "--with-libarchive --disable-gtk-doc --disable-gtk-doc-html --disable-gtk-doc-pdf --disable-man --with-smack --with-builtin-grub2-mkconfig --with-curl"
27EXTRA_OECONF_append_class-native = " --enable-wrpseudo-compat" 27EXTRA_OECONF_append_class-native = " --enable-wrpseudo-compat"
28 28
29PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}"
30PACKAGECONFIG_class-native = ""
31PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/ --with-dracut"
32
29# Path to ${prefix}/lib/ostree/ostree-grub-generator is hardcoded on the 33# Path to ${prefix}/lib/ostree/ostree-grub-generator is hardcoded on the
30# do_configure stage so we do depend on it 34# do_configure stage so we do depend on it
31SYSROOT_DIR = "${STAGING_DIR_TARGET}" 35SYSROOT_DIR = "${STAGING_DIR_TARGET}"
32SYSROOT_DIR_class-native = "${STAGING_DIR_NATIVE}" 36SYSROOT_DIR_class-native = "${STAGING_DIR_NATIVE}"
33do_configure[vardeps] += "SYSROOT_DIR" 37do_configure[vardeps] += "SYSROOT_DIR"
34 38
35SYSTEMD_REQUIRED = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}" 39SYSTEMD_SERVICE_${PN} = "ostree-prepare-root.service ostree-remount.service ostree-finalize-staged.service"
36SYSTEMD_REQUIRED_class-native = ""
37
38SYSTEMD_SERVICE_${PN} = "ostree-prepare-root.service ostree-remount.service"
39SYSTEMD_SERVICE_${PN}_class-native = ""
40
41PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}"
42PACKAGECONFIG_class-native = ""
43PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/ --with-dracut"
44
45FILES_${PN} += "${libdir}/ostree/ ${libdir}/ostbuild"
46 40
41export BUILD_SYS
42export HOST_SYS
47export STAGING_INCDIR 43export STAGING_INCDIR
48export STAGING_LIBDIR 44export STAGING_LIBDIR
49 45
50do_configure() { 46do_configure_prepend() {
51 unset docdir 47 unset docdir
52 NOCONFIGURE=1 ./autogen.sh 48 NOCONFIGURE=1 "${S}/autogen.sh"
53 oe_runconf
54}
55
56do_compile_prepend() {
57 export BUILD_SYS="${BUILD_SYS}"
58 export HOST_SYS="${HOST_SYS}"
59}
60
61export SYSTEMD_REQUIRED
62
63do_install_append() {
64 if [ -n ${SYSTEMD_REQUIRED} ]; then
65 install -p -D ${S}/src/boot/ostree-prepare-root.service ${D}${systemd_unitdir}/system/ostree-prepare-root.service
66 install -p -D ${S}/src/boot/ostree-remount.service ${D}${systemd_unitdir}/system/ostree-remount.service
67 fi
68} 49}
69 50
70do_install_append_class-native() { 51do_install_append_class-native() {
71 create_wrapper ${D}${bindir}/ostree OSTREE_GRUB2_EXEC="${STAGING_LIBDIR_NATIVE}/ostree/ostree-grub-generator" 52 create_wrapper ${D}${bindir}/ostree OSTREE_GRUB2_EXEC="${STAGING_LIBDIR_NATIVE}/ostree/ostree-grub-generator"
72} 53}
73 54
74 55PACKAGES += " \
75FILES_${PN} += " \ 56 ${PN}-switchroot \
76 ${@'${systemd_unitdir}/system/' if d.getVar('SYSTEMD_REQUIRED', True) else ''} \ 57 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'ostree-dracut', '', d)} \
77 ${@'${libdir}/dracut/modules.d/98ostree/module-setup.sh' if d.getVar('SYSTEMD_REQUIRED', True) else ''} \
78 ${datadir}/gir-1.0 \
79 ${datadir}/gir-1.0/OSTree-1.0.gir \
80 ${libdir}/girepository-1.0 \
81 ${libdir}/girepository-1.0/OSTree-1.0.typelib \
82" 58"
83 59
84PACKAGES =+ "${PN}-switchroot" 60FILES_${PN} = "${bindir} \
85 61 ${sysconfdir}/ostree \
62 ${datadir}/ostree \
63 ${libdir}/*.so.* \
64 ${libdir}/ostree/ostree-grub-generator \
65 ${libdir}/ostree/ostree-remount \
66 ${libdir}/girepository-1.0/* \
67 ${@bb.utils.contains('DISTRO_FEATURES','systemd','${libdir}/tmpfiles.d', '', d)} \
68 ${@bb.utils.contains('DISTRO_FEATURES','systemd','${systemd_unitdir}/system-generators', '', d)} \
69"
70FILES_${PN}-dev += " ${datadir}/gir-1.0"
71FILES_${PN}-dracut = "${sysconfdir}/dracut.conf.d ${libdir}/dracut"
86FILES_${PN}-switchroot = "${libdir}/ostree/ostree-prepare-root" 72FILES_${PN}-switchroot = "${libdir}/ostree/ostree-prepare-root"
87RDEPENDS_${PN}-switchroot = ""
88DEPENDS_remove_class-native = "systemd-native"
89