diff options
Diffstat (limited to 'recipes-sota/ostree-initrd')
-rw-r--r-- | recipes-sota/ostree-initrd/files/init.sh | 22 | ||||
-rw-r--r-- | recipes-sota/ostree-initrd/ostree-initrd.bb | 10 |
2 files changed, 9 insertions, 23 deletions
diff --git a/recipes-sota/ostree-initrd/files/init.sh b/recipes-sota/ostree-initrd/files/init.sh index d7e0429..4818a07 100644 --- a/recipes-sota/ostree-initrd/files/init.sh +++ b/recipes-sota/ostree-initrd/files/init.sh | |||
@@ -41,7 +41,6 @@ do_mount_fs sysfs /sys | |||
41 | do_mount_fs devtmpfs /dev | 41 | do_mount_fs devtmpfs /dev |
42 | do_mount_fs devpts /dev/pts | 42 | do_mount_fs devpts /dev/pts |
43 | do_mount_fs tmpfs /dev/shm | 43 | do_mount_fs tmpfs /dev/shm |
44 | do_mount_fs tmpfs /tmp | ||
45 | do_mount_fs tmpfs /run | 44 | do_mount_fs tmpfs /run |
46 | 45 | ||
47 | # check if smack is active (and if so, mount smackfs) | 46 | # check if smack is active (and if so, mount smackfs) |
@@ -63,23 +62,10 @@ mount "$ostree_sysroot" /sysroot || { | |||
63 | sleep 5 | 62 | sleep 5 |
64 | mount "$ostree_sysroot" /sysroot || bail_out "Unable to mount $ostree_sysroot as physical sysroot" | 63 | mount "$ostree_sysroot" /sysroot || bail_out "Unable to mount $ostree_sysroot as physical sysroot" |
65 | } | 64 | } |
66 | ostree-prepare-root /sysroot | ||
67 | |||
68 | # move mounted devices to new root | ||
69 | cd /sysroot | ||
70 | for x in dev proc run; do | ||
71 | log_info "Moving /$x to new rootfs" | ||
72 | mount -o move "/$x" "$x" | ||
73 | done | ||
74 | |||
75 | # switch to new rootfs | ||
76 | log_info "Switching to new rootfs" | ||
77 | mkdir -p run/initramfs | ||
78 | 65 | ||
79 | pivot_root . run/initramfs || bail_out "pivot_root failed." | 66 | ostree-prepare-root /sysroot |
80 | |||
81 | log_info "Launching target init" | ||
82 | 67 | ||
83 | exec chroot . sh -c 'umount /run/initramfs; exec /sbin/init' \ | 68 | log_info "Switching to rootfs" |
84 | <dev/console >dev/console 2>&1 | 69 | exec switch_root /sysroot /sbin/init |
85 | 70 | ||
71 | bail_out "Failed to switch_root to $ostree_sysroot" | ||
diff --git a/recipes-sota/ostree-initrd/ostree-initrd.bb b/recipes-sota/ostree-initrd/ostree-initrd.bb index 6046c81..26525c8 100644 --- a/recipes-sota/ostree-initrd/ostree-initrd.bb +++ b/recipes-sota/ostree-initrd/ostree-initrd.bb | |||
@@ -1,20 +1,20 @@ | |||
1 | SUMMARY = "Extremely basic live image init script" | 1 | SUMMARY = "Initramfs for booting into libostree managed system" |
2 | LICENSE = "MIT" | 2 | LICENSE = "MIT" |
3 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" | 3 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" |
4 | |||
4 | SRC_URI = "file://init.sh" | 5 | SRC_URI = "file://init.sh" |
5 | 6 | ||
6 | S = "${WORKDIR}" | 7 | S = "${WORKDIR}" |
7 | 8 | ||
8 | PV = "3" | 9 | PV = "4" |
9 | 10 | ||
10 | do_install() { | 11 | do_install() { |
11 | install -dm 0755 ${D}/etc | 12 | install -dm 0755 ${D}/etc |
12 | touch ${D}/etc/initrd-release | 13 | touch ${D}/etc/initrd-release |
13 | install -dm 0755 ${D}/dev | 14 | install -dm 0755 ${D}/dev |
14 | install -dm 0755 ${D}/sbin | 15 | install -m 0755 ${WORKDIR}/init.sh ${D}/init |
15 | install -m 0755 ${WORKDIR}/init.sh ${D}/sbin/init | ||
16 | } | 16 | } |
17 | 17 | ||
18 | inherit allarch | 18 | inherit allarch |
19 | 19 | ||
20 | FILES_${PN} += " /dev /etc/initrd-release /sbin/init " | 20 | FILES_${PN} += " /dev /etc/initrd-release /init " |