diff options
Diffstat (limited to 'recipes-sota/ostree-initrd')
-rw-r--r-- | recipes-sota/ostree-initrd/files/init.sh | 3 | ||||
-rw-r--r-- | recipes-sota/ostree-initrd/ostree-initrd.bb | 5 |
2 files changed, 5 insertions, 3 deletions
diff --git a/recipes-sota/ostree-initrd/files/init.sh b/recipes-sota/ostree-initrd/files/init.sh index 806a7b1..1814ca3 100644 --- a/recipes-sota/ostree-initrd/files/init.sh +++ b/recipes-sota/ostree-initrd/files/init.sh | |||
@@ -29,10 +29,11 @@ get_ostree_sysroot() { | |||
29 | for opt in `cat /proc/cmdline`; do | 29 | for opt in `cat /proc/cmdline`; do |
30 | arg=`echo $opt | cut -d'=' -f1` | 30 | arg=`echo $opt | cut -d'=' -f1` |
31 | if [ $arg == "ostree_root" ]; then | 31 | if [ $arg == "ostree_root" ]; then |
32 | echo $opt | cut -d'=' -f2 | 32 | echo $opt | cut -d'=' -f2- |
33 | return | 33 | return |
34 | fi | 34 | fi |
35 | done | 35 | done |
36 | echo "LABEL=otaroot" | ||
36 | } | 37 | } |
37 | 38 | ||
38 | export PATH=/sbin:/usr/sbin:/bin:/usr/bin:/usr/lib/ostree | 39 | export PATH=/sbin:/usr/sbin:/bin:/usr/bin:/usr/lib/ostree |
diff --git a/recipes-sota/ostree-initrd/ostree-initrd.bb b/recipes-sota/ostree-initrd/ostree-initrd.bb index 5c85bee..b721405 100644 --- a/recipes-sota/ostree-initrd/ostree-initrd.bb +++ b/recipes-sota/ostree-initrd/ostree-initrd.bb | |||
@@ -5,15 +5,16 @@ SRC_URI = "file://init.sh" | |||
5 | 5 | ||
6 | S = "${WORKDIR}" | 6 | S = "${WORKDIR}" |
7 | 7 | ||
8 | PV = "2" | ||
9 | |||
8 | do_install() { | 10 | do_install() { |
9 | install -dm 0755 ${D}/etc | 11 | install -dm 0755 ${D}/etc |
10 | touch ${D}/etc/initrd-release | 12 | touch ${D}/etc/initrd-release |
11 | install -dm 0755 ${D}/dev | 13 | install -dm 0755 ${D}/dev |
12 | install -dm 0755 ${D}/sbin | 14 | install -dm 0755 ${D}/sbin |
13 | install -m 0755 ${WORKDIR}/init.sh ${D}/sbin/init | 15 | install -m 0755 ${WORKDIR}/init.sh ${D}/sbin/init |
14 | } | 16 | } |
15 | 17 | ||
16 | inherit allarch | 18 | inherit allarch |
17 | 19 | ||
18 | FILES_${PN} += " /dev /etc/initrd-release /sbin/init " | 20 | FILES_${PN} += " /dev /etc/initrd-release /sbin/init " |
19 | |||