summaryrefslogtreecommitdiffstats
path: root/recipes-sota/ostree-initrd/ostree-initrd.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-sota/ostree-initrd/ostree-initrd.bb')
-rw-r--r--recipes-sota/ostree-initrd/ostree-initrd.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-sota/ostree-initrd/ostree-initrd.bb b/recipes-sota/ostree-initrd/ostree-initrd.bb
new file mode 100644
index 0000000..5c85bee
--- /dev/null
+++ b/recipes-sota/ostree-initrd/ostree-initrd.bb
@@ -0,0 +1,19 @@
1SUMMARY = "Extremely basic live image init script"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
4SRC_URI = "file://init.sh"
5
6S = "${WORKDIR}"
7
8do_install() {
9 install -dm 0755 ${D}/etc
10 touch ${D}/etc/initrd-release
11 install -dm 0755 ${D}/dev
12 install -dm 0755 ${D}/sbin
13 install -m 0755 ${WORKDIR}/init.sh ${D}/sbin/init
14}
15
16inherit allarch
17
18FILES_${PN} += " /dev /etc/initrd-release /sbin/init "
19