summaryrefslogtreecommitdiffstats
path: root/recipes-sota/libgsystem/libgsystem_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-sota/libgsystem/libgsystem_git.bb')
-rw-r--r--recipes-sota/libgsystem/libgsystem_git.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-sota/libgsystem/libgsystem_git.bb b/recipes-sota/libgsystem/libgsystem_git.bb
new file mode 100644
index 0000000..ed9638c
--- /dev/null
+++ b/recipes-sota/libgsystem/libgsystem_git.bb
@@ -0,0 +1,21 @@
1SUMMARY = "GIO-based library, targeted primarily for use by operating system components"
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
4
5SRC_URI = "gitsm://git.gnome.org/libgsystem.git"
6SRCREV="${AUTOREV}"
7
8S = "${WORKDIR}/git"
9
10DEPENDS += "attr glib-2.0 pkgconfig libcap"
11
12RDEPENDS_${PN} = "systemd liblzma"
13
14inherit autotools-brokensep
15
16BBCLASSEXTEND += "native"
17
18do_configure() {
19 NOCONFIGURE=true ./autogen.sh
20 oe_runconf
21}