summaryrefslogtreecommitdiffstats
path: root/recipes-sota/libgsystem/libgsystem_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-sota/libgsystem/libgsystem_git.bb')
-rw-r--r--recipes-sota/libgsystem/libgsystem_git.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes-sota/libgsystem/libgsystem_git.bb b/recipes-sota/libgsystem/libgsystem_git.bb
index f35819d..fe1e552 100644
--- a/recipes-sota/libgsystem/libgsystem_git.bb
+++ b/recipes-sota/libgsystem/libgsystem_git.bb
@@ -15,7 +15,23 @@ inherit autotools-brokensep
15 15
16BBCLASSEXTEND += "native" 16BBCLASSEXTEND += "native"
17 17
18export STAGING_INCDIR
19export STAGING_LIBDIR
20
18do_configure() { 21do_configure() {
19 NOCONFIGURE=true ./autogen.sh 22 NOCONFIGURE=true ./autogen.sh
20 oe_runconf 23 oe_runconf
21} 24}
25
26do_compile_prepend() {
27 export BUILD_SYS="${BUILD_SYS}"
28 export HOST_SYS="${HOST_SYS}"
29}
30
31FILES_${PN} += " \
32 ${datadir} \
33 ${datadir}/gir-1.0 \
34 ${datadir}/gir-1.0/GSystem-1.0.gir \
35 ${libdir}/girepository-1.0/ \
36 ${libdir}/girepository-1.0/GSystem-1.0.typelib \
37"