diff options
Diffstat (limited to 'recipes-sota/config')
-rw-r--r-- | recipes-sota/config/aktualizr-binary-pacman.bb | 21 | ||||
-rw-r--r-- | recipes-sota/config/files/10-pacman.toml | 2 |
2 files changed, 23 insertions, 0 deletions
diff --git a/recipes-sota/config/aktualizr-binary-pacman.bb b/recipes-sota/config/aktualizr-binary-pacman.bb new file mode 100644 index 0000000..36bafb3 --- /dev/null +++ b/recipes-sota/config/aktualizr-binary-pacman.bb | |||
@@ -0,0 +1,21 @@ | |||
1 | DESCRIPTION = "Configure aktualizr with a binary package manager" | ||
2 | LICENSE = "MPL-2.0" | ||
3 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7f619bab123dad" | ||
4 | |||
5 | inherit allarch | ||
6 | |||
7 | SRC_URI = "\ | ||
8 | file://10-pacman.toml \ | ||
9 | " | ||
10 | |||
11 | FILES_${PN} = " \ | ||
12 | ${libdir}/sota/conf.d \ | ||
13 | ${libdir}/sota/conf.d/10-pacman.toml \ | ||
14 | " | ||
15 | |||
16 | PR = "1" | ||
17 | |||
18 | do_install() { | ||
19 | install -m 0700 -d ${D}${libdir}/sota/conf.d | ||
20 | install -m 0644 ${WORKDIR}/10-pacman.toml ${D}${libdir}/sota/conf.d/10-pacman.toml | ||
21 | } | ||
diff --git a/recipes-sota/config/files/10-pacman.toml b/recipes-sota/config/files/10-pacman.toml new file mode 100644 index 0000000..a24fd39 --- /dev/null +++ b/recipes-sota/config/files/10-pacman.toml | |||
@@ -0,0 +1,2 @@ | |||
1 | [pacman] | ||
2 | type = "none" | ||