diff options
Diffstat (limited to 'recipes-sota/aktualizr/aktualizr-hsm-prov.bb')
-rw-r--r-- | recipes-sota/aktualizr/aktualizr-hsm-prov.bb | 31 |
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes-sota/aktualizr/aktualizr-hsm-prov.bb b/recipes-sota/aktualizr/aktualizr-hsm-prov.bb new file mode 100644 index 0000000..944607c --- /dev/null +++ b/recipes-sota/aktualizr/aktualizr-hsm-prov.bb | |||
@@ -0,0 +1,31 @@ | |||
1 | SUMMARY = "Aktualizr configuration with HSM support" | ||
2 | DESCRIPTION = "Systemd service and configurations for Aktualizr, the SOTA Client application written in C++" | ||
3 | HOMEPAGE = "https://github.com/advancedtelematic/aktualizr" | ||
4 | SECTION = "base" | ||
5 | LICENSE = "MPL-2.0" | ||
6 | LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE;md5=9741c346eef56131163e13b9db1241b3" | ||
7 | |||
8 | DEPENDS = "aktualizr-native" | ||
9 | RDEPENDS_${PN} = "aktualizr softhsm softhsm-testtoken" | ||
10 | |||
11 | SRC_URI = " \ | ||
12 | file://LICENSE \ | ||
13 | " | ||
14 | PV = "1.0" | ||
15 | PR = "6" | ||
16 | |||
17 | |||
18 | require environment.inc | ||
19 | require credentials.inc | ||
20 | |||
21 | do_install() { | ||
22 | install -d ${D}${libdir}/sota | ||
23 | aktualizr_implicit_writer -c ${SOTA_PACKED_CREDENTIALS} --no-root-ca \ | ||
24 | -i ${STAGING_DIR_NATIVE}${libdir}/sota/sota_hsm_prov.toml -o ${D}${libdir}/sota/sota.toml -p ${D} | ||
25 | } | ||
26 | |||
27 | FILES_${PN} = " \ | ||
28 | ${libdir}/sota/sota.toml \ | ||
29 | " | ||
30 | |||
31 | # vim:set ts=4 sw=4 sts=4 expandtab: | ||