diff options
Diffstat (limited to 'recipes-extended/ostree/ostree')
-rw-r--r-- | recipes-extended/ostree/ostree/0001-Makefile-declare-ostree_boot_SCRIPTS-and-append-valu.patch | 60 |
1 files changed, 60 insertions, 0 deletions
diff --git a/recipes-extended/ostree/ostree/0001-Makefile-declare-ostree_boot_SCRIPTS-and-append-valu.patch b/recipes-extended/ostree/ostree/0001-Makefile-declare-ostree_boot_SCRIPTS-and-append-valu.patch new file mode 100644 index 0000000..1f8a06b --- /dev/null +++ b/recipes-extended/ostree/ostree/0001-Makefile-declare-ostree_boot_SCRIPTS-and-append-valu.patch | |||
@@ -0,0 +1,60 @@ | |||
1 | From de8e0765a4a54f0367999f682ce4cc53bfaa60b0 Mon Sep 17 00:00:00 2001 | ||
2 | From: Ricardo Salveti <ricardo@foundries.io> | ||
3 | Date: Tue, 5 Nov 2019 21:16:07 -0300 | ||
4 | Subject: [PATCH] Makefile: declare ostree_boot_SCRIPTS and append values | ||
5 | |||
6 | ostree_boot_SCRIPTS was being set on both Makefile-boot.am and | ||
7 | Makefile-switchroot.am, causing the first one to be replaced by the | ||
8 | other at the final Makefile, so declare as empty and append on both | ||
9 | places instead. | ||
10 | |||
11 | Upstream-Status: Backport | ||
12 | |||
13 | Signed-off-by: Ricardo Salveti <ricardo@foundries.io> | ||
14 | --- | ||
15 | Makefile-boot.am | 2 +- | ||
16 | Makefile-decls.am | 1 + | ||
17 | Makefile-switchroot.am | 2 +- | ||
18 | 3 files changed, 3 insertions(+), 2 deletions(-) | ||
19 | |||
20 | diff --git a/Makefile-boot.am b/Makefile-boot.am | ||
21 | index b4d4a1af..b51928f0 100644 | ||
22 | --- a/Makefile-boot.am | ||
23 | +++ b/Makefile-boot.am | ||
24 | @@ -60,7 +60,7 @@ grub2configdir = $(sysconfdir)/grub.d | ||
25 | INSTALL_DATA_HOOKS += install-grub2-config-hook | ||
26 | else | ||
27 | # We're using our internal generator | ||
28 | -ostree_boot_SCRIPTS = src/boot/grub2/ostree-grub-generator | ||
29 | +ostree_boot_SCRIPTS += src/boot/grub2/ostree-grub-generator | ||
30 | endif | ||
31 | |||
32 | EXTRA_DIST += src/boot/dracut/module-setup.sh \ | ||
33 | diff --git a/Makefile-decls.am b/Makefile-decls.am | ||
34 | index 115c19fb..086ee138 100644 | ||
35 | --- a/Makefile-decls.am | ||
36 | +++ b/Makefile-decls.am | ||
37 | @@ -47,6 +47,7 @@ typelibdir = $(libdir)/girepository-1.0 | ||
38 | typelib_DATA = | ||
39 | gsettings_SCHEMAS = | ||
40 | ostree_bootdir = $(prefix)/lib/ostree | ||
41 | +ostree_boot_SCRIPTS = | ||
42 | ostree_boot_PROGRAMS = | ||
43 | |||
44 | # This initializes some more variables | ||
45 | diff --git a/Makefile-switchroot.am b/Makefile-switchroot.am | ||
46 | index ff44d4bc..b81b843f 100644 | ||
47 | --- a/Makefile-switchroot.am | ||
48 | +++ b/Makefile-switchroot.am | ||
49 | @@ -42,7 +42,7 @@ if BUILDOPT_USE_STATIC_COMPILER | ||
50 | # to get autotools to install this as an executable but without generating rules | ||
51 | # to make it itself which we have specified manually. See | ||
52 | # https://lists.gnu.org/archive/html/help-gnu-utils/2007-01/msg00007.html | ||
53 | -ostree_boot_SCRIPTS = ostree-prepare-root | ||
54 | +ostree_boot_SCRIPTS += ostree-prepare-root | ||
55 | |||
56 | ostree-prepare-root : $(ostree_prepare_root_SOURCES) | ||
57 | $(STATIC_COMPILER) -o $@ -static $(top_srcdir)/src/switchroot/ostree-prepare-root.c $(ostree_prepare_root_CPPFLAGS) $(AM_CFLAGS) $(DEFAULT_INCLUDES) -DOSTREE_PREPARE_ROOT_STATIC=1 | ||
58 | -- | ||
59 | 2.24.0 | ||
60 | |||