diff options
Diffstat (limited to 'recipes-devtools')
5 files changed, 0 insertions, 66 deletions
diff --git a/recipes-devtools/pseudo/files/0001-Add-check-for-existence-of-old-file-to-renameat.patch b/recipes-devtools/pseudo/files/0001-Add-check-for-existence-of-old-file-to-renameat.patch deleted file mode 100644 index 3da2ad7..0000000 --- a/recipes-devtools/pseudo/files/0001-Add-check-for-existence-of-old-file-to-renameat.patch +++ /dev/null | |||
@@ -1,40 +0,0 @@ | |||
1 | From 41bb6c818a7ec9eeb33b60302c55c9c5ee393c5f Mon Sep 17 00:00:00 2001 | ||
2 | From: Anton Gerasimov <anton@advancedtelematic.com> | ||
3 | Date: Fri, 30 Sep 2016 17:12:19 +0200 | ||
4 | Subject: [PATCH 1/1] Add check for existence of old file to renameat | ||
5 | |||
6 | --- | ||
7 | ports/unix/guts/renameat.c | 7 ++++++- | ||
8 | 1 file changed, 6 insertions(+), 1 deletion(-) | ||
9 | |||
10 | diff --git a/ports/unix/guts/renameat.c b/ports/unix/guts/renameat.c | ||
11 | index ade0509..d5e36fa 100644 | ||
12 | --- a/ports/unix/guts/renameat.c | ||
13 | +++ b/ports/unix/guts/renameat.c | ||
14 | @@ -11,6 +11,7 @@ | ||
15 | int oldrc, newrc; | ||
16 | int save_errno; | ||
17 | int old_db_entry = 0; | ||
18 | + int may_unlinked = 0; | ||
19 | |||
20 | pseudo_debug(PDBGF_FILE, "renameat: %d,%s->%d,%s\n", | ||
21 | olddirfd, oldpath ? oldpath : "<nil>", | ||
22 | @@ -44,10 +45,14 @@ | ||
23 | /* as with unlink, we have to mark that the file may get deleted */ | ||
24 | msg = pseudo_client_op(OP_MAY_UNLINK, 0, -1, newdirfd, newpath, newrc ? NULL : &newbuf); | ||
25 | if (msg && msg->result == RESULT_SUCCEED) | ||
26 | + may_unlinked = 1; | ||
27 | + msg = pseudo_client_op(OP_STAT, 0, -1, olddirfd, oldpath, oldrc ? NULL : &oldbuf); | ||
28 | + if (msg && msg->result == RESULT_SUCCEED) | ||
29 | old_db_entry = 1; | ||
30 | + | ||
31 | rc = real_renameat(olddirfd, oldpath, newdirfd, newpath); | ||
32 | save_errno = errno; | ||
33 | - if (old_db_entry) { | ||
34 | + if (may_unlinked) { | ||
35 | if (rc == -1) { | ||
36 | /* since we failed, that wasn't really unlinked -- put | ||
37 | * it back. | ||
38 | -- | ||
39 | 2.9.3 | ||
40 | |||
diff --git a/recipes-devtools/pseudo/files/fallback-group b/recipes-devtools/pseudo/files/fallback-group deleted file mode 100644 index 81bf732..0000000 --- a/recipes-devtools/pseudo/files/fallback-group +++ /dev/null | |||
@@ -1,2 +0,0 @@ | |||
1 | root:*:0: | ||
2 | mail:*:8: | ||
diff --git a/recipes-devtools/pseudo/files/fallback-passwd b/recipes-devtools/pseudo/files/fallback-passwd deleted file mode 100644 index c1458dc..0000000 --- a/recipes-devtools/pseudo/files/fallback-passwd +++ /dev/null | |||
@@ -1 +0,0 @@ | |||
1 | root::0:0:root:/home/root:/bin/sh | ||
diff --git a/recipes-devtools/pseudo/pseudo_1.7.5.bbappend b/recipes-devtools/pseudo/pseudo_1.7.5.bbappend deleted file mode 100644 index 73b43df..0000000 --- a/recipes-devtools/pseudo/pseudo_1.7.5.bbappend +++ /dev/null | |||
@@ -1,3 +0,0 @@ | |||
1 | FILESEXTRAPATHS_prepend := "${THISDIR}/files:" | ||
2 | |||
3 | SRC_URI += "file://0001-Add-check-for-existence-of-old-file-to-renameat.patch" | ||
diff --git a/recipes-devtools/pseudo/pseudo_1.8.1.bb b/recipes-devtools/pseudo/pseudo_1.8.1.bb deleted file mode 100644 index 211439e..0000000 --- a/recipes-devtools/pseudo/pseudo_1.8.1.bb +++ /dev/null | |||
@@ -1,20 +0,0 @@ | |||
1 | require recipes-devtools/pseudo/pseudo.inc | ||
2 | |||
3 | SRC_URI = " \ | ||
4 | http://downloads.yoctoproject.org/releases/pseudo/${BPN}-${PV}.tar.bz2 \ | ||
5 | file://fallback-passwd \ | ||
6 | file://fallback-group \ | ||
7 | file://0001-Add-check-for-existence-of-old-file-to-renameat.patch \ | ||
8 | " | ||
9 | |||
10 | SRC_URI[md5sum] = "ee38e4fb62ff88ad067b1a5a3825bac7" | ||
11 | SRC_URI[sha256sum] = "dac4ad2d21228053151121320f629d41dd5c0c87695ac4e7aea286c414192ab5" | ||
12 | |||
13 | PSEUDO_EXTRA_OPTS ?= "--enable-force-async --without-passwd-fallback" | ||
14 | |||
15 | do_install_append_class-native () { | ||
16 | install -d ${D}${sysconfdir} | ||
17 | # The fallback files should never be modified | ||
18 | install -m 444 ${WORKDIR}/fallback-passwd ${D}${sysconfdir}/passwd | ||
19 | install -m 444 ${WORKDIR}/fallback-group ${D}${sysconfdir}/group | ||
20 | } | ||