summaryrefslogtreecommitdiffstats
path: root/recipes-core
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/images/initramfs-ostree-image.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-core/images/initramfs-ostree-image.bb b/recipes-core/images/initramfs-ostree-image.bb
new file mode 100644
index 0000000..71aa631
--- /dev/null
+++ b/recipes-core/images/initramfs-ostree-image.bb
@@ -0,0 +1,23 @@
1# Netboot initramfs image.
2DESCRIPTION = "OSTree initramfs image"
3
4PACKAGE_INSTALL = "ostree ostree-initramfs systemd-initramfs busybox base-passwd ${ROOTFS_BOOTSTRAP_INSTALL}"
5
6SYSTEMD_DEFAULT_TARGET = "initrd.target"
7
8# Do not pollute the initrd image with rootfs features
9IMAGE_FEATURES = ""
10
11export IMAGE_BASENAME = "initramfs-ostree-image"
12IMAGE_LINGUAS = ""
13
14LICENSE = "MIT"
15
16IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
17inherit core-image
18
19IMAGE_ROOTFS_SIZE = "8192"
20
21BAD_RECOMMENDATIONS += "busybox-syslog"
22
23