diff options
Diffstat (limited to 'recipes-connectivity')
-rw-r--r-- | recipes-connectivity/openssl/files/0001-Fix-broken-change-from-b3d113e.patch | 29 | ||||
-rw-r--r-- | recipes-connectivity/openssl/openssl_1.1.1c.bbappend | 4 |
2 files changed, 33 insertions, 0 deletions
diff --git a/recipes-connectivity/openssl/files/0001-Fix-broken-change-from-b3d113e.patch b/recipes-connectivity/openssl/files/0001-Fix-broken-change-from-b3d113e.patch new file mode 100644 index 0000000..b176cc7 --- /dev/null +++ b/recipes-connectivity/openssl/files/0001-Fix-broken-change-from-b3d113e.patch | |||
@@ -0,0 +1,29 @@ | |||
1 | From 711a161f03ef9ed7cd149a22bf1203700c103e96 Mon Sep 17 00:00:00 2001 | ||
2 | From: Pauli <paul.dale@oracle.com> | ||
3 | Date: Fri, 29 Mar 2019 09:24:07 +1000 | ||
4 | Subject: [PATCH] Fix broken change from b3d113e. | ||
5 | |||
6 | Reviewed-by: Tim Hudson <tjh@openssl.org> | ||
7 | (Merged from https://github.com/openssl/openssl/pull/8606) | ||
8 | --- | ||
9 | crypto/rand/rand_lib.c | 3 ++- | ||
10 | 1 file changed, 2 insertions(+), 1 deletion(-) | ||
11 | |||
12 | diff --git a/crypto/rand/rand_lib.c b/crypto/rand/rand_lib.c | ||
13 | index 23abbde156..a298b7515b 100644 | ||
14 | --- a/crypto/rand/rand_lib.c | ||
15 | +++ b/crypto/rand/rand_lib.c | ||
16 | @@ -235,8 +235,9 @@ size_t rand_drbg_get_nonce(RAND_DRBG *drbg, | ||
17 | struct { | ||
18 | void * instance; | ||
19 | int count; | ||
20 | - } data = { NULL, 0 }; | ||
21 | + } data; | ||
22 | |||
23 | + memset(&data, 0, sizeof(data)); | ||
24 | pool = rand_pool_new(0, min_len, max_len); | ||
25 | if (pool == NULL) | ||
26 | return 0; | ||
27 | -- | ||
28 | 2.20.1 | ||
29 | |||
diff --git a/recipes-connectivity/openssl/openssl_1.1.1c.bbappend b/recipes-connectivity/openssl/openssl_1.1.1c.bbappend new file mode 100644 index 0000000..85fca9b --- /dev/null +++ b/recipes-connectivity/openssl/openssl_1.1.1c.bbappend | |||
@@ -0,0 +1,4 @@ | |||
1 | FILESEXTRAPATHS_prepend := "${THISDIR}/files:" | ||
2 | |||
3 | # from https://github.com/openssl/openssl/pull/8606 | ||
4 | SRC_URI += "file://0001-Fix-broken-change-from-b3d113e.patch" | ||