summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/bootfiles/bcm2835-bootfiles.bbappend1
-rw-r--r--recipes-bsp/bootfiles/rpi-config_git.bbappend3
-rw-r--r--recipes-bsp/u-boot-otascript/u-boot-otascript.bb26
-rw-r--r--recipes-bsp/u-boot-otascript/u-boot-otascript/boot.scr3
-rw-r--r--recipes-bsp/u-boot-otascript/u-boot-otascript/uEnv.txt7
-rw-r--r--recipes-bsp/u-boot/u-boot_2016.11.bb7
6 files changed, 47 insertions, 0 deletions
diff --git a/recipes-bsp/bootfiles/bcm2835-bootfiles.bbappend b/recipes-bsp/bootfiles/bcm2835-bootfiles.bbappend
new file mode 100644
index 0000000..74aa6b1
--- /dev/null
+++ b/recipes-bsp/bootfiles/bcm2835-bootfiles.bbappend
@@ -0,0 +1 @@
RDEPENDS_${PN} += " u-boot-otascript"
diff --git a/recipes-bsp/bootfiles/rpi-config_git.bbappend b/recipes-bsp/bootfiles/rpi-config_git.bbappend
new file mode 100644
index 0000000..6e53993
--- /dev/null
+++ b/recipes-bsp/bootfiles/rpi-config_git.bbappend
@@ -0,0 +1,3 @@
1do_deploy_append() {
2 echo "device_tree_address=0x0c800000" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
3}
diff --git a/recipes-bsp/u-boot-otascript/u-boot-otascript.bb b/recipes-bsp/u-boot-otascript/u-boot-otascript.bb
new file mode 100644
index 0000000..9f5f0ca
--- /dev/null
+++ b/recipes-bsp/u-boot-otascript/u-boot-otascript.bb
@@ -0,0 +1,26 @@
1DESCRIPTION = "Boot script for launching OTA-enabled images on raspberrypi"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
4
5DEPENDS = "u-boot-mkimage-native"
6
7COMPATIBLE_MACHINE = "raspberrypi"
8
9SRC_URI = "file://boot.scr \
10 file://uEnv.txt"
11
12S = "${WORKDIR}"
13
14inherit deploy
15
16do_deploy() {
17 install -d ${DEPLOYDIR}/bcm2835-bootfiles
18
19 mkimage -A arm -O linux -T script -C none -a 0 -e 0 -n "Ostree boot script" -d ${S}/boot.scr ${DEPLOYDIR}/bcm2835-bootfiles/boot.scr
20 install -m 0755 ${S}/uEnv.txt ${DEPLOYDIR}/bcm2835-bootfiles/uEnv.txt
21}
22
23addtask deploy before do_package after do_install
24do_deploy[dirs] += "${DEPLOYDIR}/bcm2835-bootfiles"
25
26PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/recipes-bsp/u-boot-otascript/u-boot-otascript/boot.scr b/recipes-bsp/u-boot-otascript/u-boot-otascript/boot.scr
new file mode 100644
index 0000000..dc13f85
--- /dev/null
+++ b/recipes-bsp/u-boot-otascript/u-boot-otascript/boot.scr
@@ -0,0 +1,3 @@
1fatload mmc 0:1 $loadaddr /uEnv.txt
2env import -t $loadaddr $filesize
3run bootcmd
diff --git a/recipes-bsp/u-boot-otascript/u-boot-otascript/uEnv.txt b/recipes-bsp/u-boot-otascript/u-boot-otascript/uEnv.txt
new file mode 100644
index 0000000..f6c0570
--- /dev/null
+++ b/recipes-bsp/u-boot-otascript/u-boot-otascript/uEnv.txt
@@ -0,0 +1,7 @@
1fdt_addr_r=0x0c800000
2bootcmd_dtb=fdt addr $fdt_addr_r; fdt get value bootargs_fdt /chosen bootargs
3bootcmd_otenv=ext2load mmc 0:2 $loadaddr /boot/loader/uEnv.txt; env import -t $loadaddr $filesize
4bootcmd_args=setenv bootargs "$bootargs $bootargs_fdt ostree_root=/dev/mmcblk0p2 root=/dev/ram0 rw rootwait rootdelay=2 ramdisk_size=8192"
5bootcmd_load=ext2load mmc 0:2 $kernel_addr_r "/boot"$kernel_image; ext2load mmc 0:2 $ramdisk_addr_r "/boot"$ramdisk_image
6bootcmd_run=bootm $kernel_addr_r $ramdisk_addr_r $fdt_addr_r
7bootcmd=run bootcmd_dtb; run bootcmd_otenv; run bootcmd_args; run bootcmd_load; run bootcmd_run
diff --git a/recipes-bsp/u-boot/u-boot_2016.11.bb b/recipes-bsp/u-boot/u-boot_2016.11.bb
new file mode 100644
index 0000000..a05b37f
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot_2016.11.bb
@@ -0,0 +1,7 @@
1require recipes-bsp/u-boot/u-boot.inc
2
3DEPENDS += "dtc-native"
4
5SRCREV = "5ea3e51fc481613a8dee8c02848d1b42c81ad892"
6
7PV = "v2016.11+git${SRCPV}"