summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot-otascript/u-boot-otascript.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot-otascript/u-boot-otascript.bb')
-rw-r--r--recipes-bsp/u-boot-otascript/u-boot-otascript.bb26
1 files changed, 0 insertions, 26 deletions
diff --git a/recipes-bsp/u-boot-otascript/u-boot-otascript.bb b/recipes-bsp/u-boot-otascript/u-boot-otascript.bb
deleted file mode 100644
index 9f5f0ca..0000000
--- a/recipes-bsp/u-boot-otascript/u-boot-otascript.bb
+++ /dev/null
@@ -1,26 +0,0 @@
1DESCRIPTION = "Boot script for launching OTA-enabled images on raspberrypi"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
4
5DEPENDS = "u-boot-mkimage-native"
6
7COMPATIBLE_MACHINE = "raspberrypi"
8
9SRC_URI = "file://boot.scr \
10 file://uEnv.txt"
11
12S = "${WORKDIR}"
13
14inherit deploy
15
16do_deploy() {
17 install -d ${DEPLOYDIR}/bcm2835-bootfiles
18
19 mkimage -A arm -O linux -T script -C none -a 0 -e 0 -n "Ostree boot script" -d ${S}/boot.scr ${DEPLOYDIR}/bcm2835-bootfiles/boot.scr
20 install -m 0755 ${S}/uEnv.txt ${DEPLOYDIR}/bcm2835-bootfiles/uEnv.txt
21}
22
23addtask deploy before do_package after do_install
24do_deploy[dirs] += "${DEPLOYDIR}/bcm2835-bootfiles"
25
26PACKAGE_ARCH = "${MACHINE_ARCH}"