summaryrefslogtreecommitdiffstats
path: root/meta-sota-minnowboard/recipes-bsp/u-boot/u-boot-ota_2016.11.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-sota-minnowboard/recipes-bsp/u-boot/u-boot-ota_2016.11.bb')
-rw-r--r--meta-sota-minnowboard/recipes-bsp/u-boot/u-boot-ota_2016.11.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-sota-minnowboard/recipes-bsp/u-boot/u-boot-ota_2016.11.bb b/meta-sota-minnowboard/recipes-bsp/u-boot/u-boot-ota_2016.11.bb
new file mode 100644
index 0000000..fe60489
--- /dev/null
+++ b/meta-sota-minnowboard/recipes-bsp/u-boot/u-boot-ota_2016.11.bb
@@ -0,0 +1,35 @@
1include recipes-bsp/u-boot/u-boot.inc
2DEPENDS += "dtc-native intel-fsp-native iasl-native"
3
4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6"
6
7# This revision corresponds to the tag "v2016.11"
8# We use the revision in order to avoid having to fetch it from the
9# repo during parse
10SRCREV = "29e0cfb4f77f7aa369136302cee14a91e22dca71"
11
12SRC_URI += "file://0002-Replace-wraps-with-built-in-code-to-remove-dependenc.patch \
13 http://firmware.intel.com/sites/default/files/MinnowBoard.MAX_.X64.92.R01.zip \
14 "
15
16# Hashes for MinnowBoard.MAX_.X64.92.R01.zip
17SRC_URI[md5sum] = "236070e3d0fb193e03a102939822cf59"
18SRC_URI[sha256sum] = "708f00d835cc9c49df4e937ef59852ccb6b95026291ac9779b5411dd09baed1f"
19
20PV = "v2016.11+git${SRCPV}"
21
22EXTRA_OEMAKE_append = " KCFLAGS=-fgnu89-inline BUILD_ROM=y"
23
24UBOOT_SUFFIX = "rom"
25
26do_configure_prepend() {
27 make ${UBOOT_MACHINE}
28 make tools
29 ./tools/ifdtool -x ${WORKDIR}/MNW2MAX1.X64.0092.R01.1605221712.bin
30 cp flashregion_0_flashdescriptor.bin ./board/intel/minnowmax/descriptor.bin
31 cp flashregion_2_intel_me.bin ./board/intel/minnowmax/me.bin
32 cp ${STAGING_DIR_NATIVE}/${datadir}/IntelFsp/BayTrailFSP.fd ./board/intel/minnowmax/fsp.bin
33 cp ${STAGING_DIR_NATIVE}/${datadir}/IntelFsp/Vga.dat ./board/intel/minnowmax/vga.bin
34}
35