summaryrefslogtreecommitdiffstats
path: root/meta-sota-minnowboard/recipes-bsp/u-boot/u-boot-ota_2015.07.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-sota-minnowboard/recipes-bsp/u-boot/u-boot-ota_2015.07.bb')
-rw-r--r--meta-sota-minnowboard/recipes-bsp/u-boot/u-boot-ota_2015.07.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-sota-minnowboard/recipes-bsp/u-boot/u-boot-ota_2015.07.bb b/meta-sota-minnowboard/recipes-bsp/u-boot/u-boot-ota_2015.07.bb
new file mode 100644
index 0000000..28b9369
--- /dev/null
+++ b/meta-sota-minnowboard/recipes-bsp/u-boot/u-boot-ota_2015.07.bb
@@ -0,0 +1,35 @@
1include recipes-bsp/u-boot/u-boot.inc
2DEPENDS += "dtc-native intel-fsp-native"
3
4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://Licenses/README;md5=0507cd7da8e7ad6d6701926ec9b84c95"
6
7# This revision corresponds to the tag "v2015.07"
8# We use the revision in order to avoid having to fetch it from the
9# repo during parse
10SRCREV = "baba2f57e8f4ed3fa67fe213d22da0de5e00f204"
11
12SRC_URI += "file://0002-Replace-wraps-with-built-in-code-to-remove-dependenc.patch \
13 http://firmware.intel.com/sites/default/files/2014-WW42.4-MinnowBoardMax.73-64-bit.bin_Release.zip \
14 "
15
16# Hashes for 2014-WW42.4-MinnowBoardMax.73-64-bit.bin_Release.zip
17SRC_URI[md5sum] = "1a4256c64a0d846b81d2adf7ce07cce5"
18SRC_URI[sha256sum] = "883b1399b89e8e13033367e911a1e69423dffa9a6c4b5d306fc070d9ed7412b7"
19
20PV = "v2015.07+git${SRCPV}"
21
22EXTRA_OEMAKE_append = " KCFLAGS=-fgnu89-inline BUILD_ROM=y"
23
24UBOOT_SUFFIX = "rom"
25
26do_configure_prepend() {
27 make ${UBOOT_MACHINE}
28 make tools
29 ./tools/ifdtool -x ${WORKDIR}/MNW2MAX1.X64.0073.R02.1409160934.bin
30 cp flashregion_0_flashdescriptor.bin ./board/intel/minnowmax/descriptor.bin
31 cp flashregion_2_intel_me.bin ./board/intel/minnowmax/me.bin
32 cp ${STAGING_DIR_NATIVE}/${datadir}/IntelFsp/BayTrailFSP.fd ./board/intel/minnowmax/fsp.bin
33 cp ${STAGING_DIR_NATIVE}/${datadir}/IntelFsp/Vga.dat ./board/intel/minnowmax/vga.bin
34}
35