summaryrefslogtreecommitdiffstats
path: root/meta-sota-minnowboard/recipes-bsp/u-boot/u-boot-ota/0002-Replace-wraps-with-built-in-code-to-remove-dependenc.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-sota-minnowboard/recipes-bsp/u-boot/u-boot-ota/0002-Replace-wraps-with-built-in-code-to-remove-dependenc.patch')
-rw-r--r--meta-sota-minnowboard/recipes-bsp/u-boot/u-boot-ota/0002-Replace-wraps-with-built-in-code-to-remove-dependenc.patch138
1 files changed, 138 insertions, 0 deletions
diff --git a/meta-sota-minnowboard/recipes-bsp/u-boot/u-boot-ota/0002-Replace-wraps-with-built-in-code-to-remove-dependenc.patch b/meta-sota-minnowboard/recipes-bsp/u-boot/u-boot-ota/0002-Replace-wraps-with-built-in-code-to-remove-dependenc.patch
new file mode 100644
index 0000000..7540b74
--- /dev/null
+++ b/meta-sota-minnowboard/recipes-bsp/u-boot/u-boot-ota/0002-Replace-wraps-with-built-in-code-to-remove-dependenc.patch
@@ -0,0 +1,138 @@
1From ab0d7e270d89f6eb99582197d2d58bf60c9c3d26 Mon Sep 17 00:00:00 2001
2From: Anton Gerasimov <anton@advancedtelematic.com>
3Date: Thu, 15 Sep 2016 16:49:32 +0200
4Subject: [PATCH 2/2] Replace wraps with built-in code to remove dependency on
5 multilib
6
7---
8 arch/x86/config.mk | 2 --
9 arch/x86/lib/gcc.c | 104 ++++++++++++++++++++++++++++++++++++++++++++---------
10 2 files changed, 87 insertions(+), 19 deletions(-)
11
12diff --git a/arch/x86/config.mk b/arch/x86/config.mk
13index 999143e..139576e 100644
14--- a/arch/x86/config.mk
15+++ b/arch/x86/config.mk
16@@ -22,5 +22,3 @@ PLATFORM_RELFLAGS += -ffunction-sections -fvisibility=hidden
17 PLATFORM_LDFLAGS += --emit-relocs -Bsymbolic -Bsymbolic-functions -m elf_i386
18
19 LDFLAGS_FINAL += --gc-sections -pie
20-LDFLAGS_FINAL += --wrap=__divdi3 --wrap=__udivdi3
21-LDFLAGS_FINAL += --wrap=__moddi3 --wrap=__umoddi3
22diff --git a/arch/x86/lib/gcc.c b/arch/x86/lib/gcc.c
23index 497ad75..c321b11 100644
24--- a/arch/x86/lib/gcc.c
25+++ b/arch/x86/lib/gcc.c
26@@ -19,22 +19,92 @@
27
28 #ifdef __GNUC__
29
30-/*
31- * GCC's libgcc handling is quite broken. While the libgcc functions
32- * are always regparm(0) the code that calls them uses whatever the
33- * compiler call specifies. Therefore we need a wrapper around those
34- * functions. See gcc bug PR41055 for more information.
35- */
36-#define WRAP_LIBGCC_CALL(type, name) \
37- type __normal_##name(type a, type b) __attribute__((regparm(0))); \
38- type __wrap_##name(type a, type b); \
39- type __attribute__((no_instrument_function)) \
40- __wrap_##name(type a, type b) \
41- { return __normal_##name(a, b); }
42-
43-WRAP_LIBGCC_CALL(long long, __divdi3)
44-WRAP_LIBGCC_CALL(unsigned long long, __udivdi3)
45-WRAP_LIBGCC_CALL(long long, __moddi3)
46-WRAP_LIBGCC_CALL(unsigned long long, __umoddi3)
47+#include <stdint.h>
48+#include <stddef.h>
49+
50+uint64_t __udivmoddi4 ( uint64_t num,
51+ uint64_t den,
52+ uint64_t *rem_p )
53+{
54+ uint64_t quot = 0, qbit = 1;
55+
56+ if ( den == 0 ) {
57+ return 1/((unsigned)den); /* Intentional divide by zero, without
58+ triggering a compiler warning which
59+ would abort the build */
60+ }
61+
62+ /* Left-justify denominator and count shift */
63+ while ( (int64_t)den >= 0 ) {
64+ den <<= 1;
65+ qbit <<= 1;
66+ }
67+
68+ while ( qbit ) {
69+ if ( den <= num ) {
70+ num -= den;
71+ quot += qbit;
72+ }
73+ den >>= 1;
74+ qbit >>= 1;
75+ }
76+
77+ if ( rem_p )
78+ *rem_p = num;
79+
80+ return quot;
81+}
82+uint64_t __udivdi3( uint64_t num, uint64_t den )
83+{
84+ return __udivmoddi4(num, den, NULL);
85+}
86+
87+uint64_t __umoddi3 ( uint64_t num, uint64_t den )
88+{
89+ uint64_t v;
90+
91+ (void) __udivmoddi4(num, den, &v);
92+ return v;
93+}
94+
95+int64_t __divmoddi4 ( int64_t num,
96+ int64_t den,
97+ int64_t* rem_p )
98+{
99+ int minus = 0;
100+ int64_t v;
101+
102+ if ( num < 0 ) {
103+ num = -num;
104+ minus = 1;
105+ }
106+ if ( den < 0 ) {
107+ den = -den;
108+ minus ^= 1;
109+ }
110+
111+ v = __udivmoddi4(num, den, (uint64_t *)rem_p);
112+ if ( minus ) {
113+ v = -v;
114+ if ( rem_p )
115+ *rem_p = -(*rem_p);
116+ }
117+
118+ return v;
119+}
120+
121+
122+int64_t __moddi3 (int64_t num, int64_t den)
123+{
124+ int64_t v;
125+
126+ (void) __divmoddi4(num, den, &v);
127+ return v;
128+}
129+
130+int64_t __divdi3(int64_t num, int64_t den)
131+{
132+ return __divmoddi4(num, den, NULL);
133+}
134
135 #endif
136--
1372.9.3
138