summaryrefslogtreecommitdiffstats
path: root/meta-sota-minnowboard/recipes-bsp/bootfiles/minnowboard-efi-startup.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-sota-minnowboard/recipes-bsp/bootfiles/minnowboard-efi-startup.bb')
-rw-r--r--meta-sota-minnowboard/recipes-bsp/bootfiles/minnowboard-efi-startup.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta-sota-minnowboard/recipes-bsp/bootfiles/minnowboard-efi-startup.bb b/meta-sota-minnowboard/recipes-bsp/bootfiles/minnowboard-efi-startup.bb
new file mode 100644
index 0000000..0ad740b
--- /dev/null
+++ b/meta-sota-minnowboard/recipes-bsp/bootfiles/minnowboard-efi-startup.bb
@@ -0,0 +1,11 @@
1DESCRIPTION = "startup.nsh for minnowboard using grub"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
4
5COMPATIBLE_MACHINE = "intel-corei7-64"
6ALLOW_EMPTY_${PN} = "1"
7
8do_install() {
9 echo "fs0:\EFI\BOOT\bootx64.efi" > ${DEPLOY_DIR_IMAGE}/startup.nsh
10}
11