diff options
Diffstat (limited to 'meta-sota-minnowboard/recipes-bsp/bootfiles/minnowboard-bootfiles.bb')
-rw-r--r-- | meta-sota-minnowboard/recipes-bsp/bootfiles/minnowboard-bootfiles.bb | 25 |
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-sota-minnowboard/recipes-bsp/bootfiles/minnowboard-bootfiles.bb b/meta-sota-minnowboard/recipes-bsp/bootfiles/minnowboard-bootfiles.bb new file mode 100644 index 0000000..74d1f18 --- /dev/null +++ b/meta-sota-minnowboard/recipes-bsp/bootfiles/minnowboard-bootfiles.bb | |||
@@ -0,0 +1,25 @@ | |||
1 | DESCRIPTION = "Boot files (bootscripts etc.) for Minnowboard Max/Turbot" | ||
2 | LICENSE = "MIT" | ||
3 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" | ||
4 | |||
5 | inherit deploy | ||
6 | |||
7 | COMPATIBLE_MACHINE = "intel-corei7-64" | ||
8 | |||
9 | S = "${WORKDIR}" | ||
10 | |||
11 | SRC_URI_append_sota = "file://uEnv-ota.txt" | ||
12 | |||
13 | do_deploy() { | ||
14 | install -d ${DEPLOYDIR}/${PN} | ||
15 | } | ||
16 | |||
17 | do_deploy_append_sota() { | ||
18 | install -m 0755 ${WORKDIR}/uEnv-ota.txt ${DEPLOYDIR}/${PN}/uEnv.txt | ||
19 | } | ||
20 | |||
21 | addtask deploy before do_package after do_install | ||
22 | do_deploy[dirs] += "${DEPLOYDIR}/${PN}" | ||
23 | |||
24 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
25 | |||