summaryrefslogtreecommitdiffstats
path: root/meta-sota-minnowboard/recipes-bsp/bootfiles/minnowboard-bootfiles.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-sota-minnowboard/recipes-bsp/bootfiles/minnowboard-bootfiles.bb')
-rw-r--r--meta-sota-minnowboard/recipes-bsp/bootfiles/minnowboard-bootfiles.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-sota-minnowboard/recipes-bsp/bootfiles/minnowboard-bootfiles.bb b/meta-sota-minnowboard/recipes-bsp/bootfiles/minnowboard-bootfiles.bb
new file mode 100644
index 0000000..74d1f18
--- /dev/null
+++ b/meta-sota-minnowboard/recipes-bsp/bootfiles/minnowboard-bootfiles.bb
@@ -0,0 +1,25 @@
1DESCRIPTION = "Boot files (bootscripts etc.) for Minnowboard Max/Turbot"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
4
5inherit deploy
6
7COMPATIBLE_MACHINE = "intel-corei7-64"
8
9S = "${WORKDIR}"
10
11SRC_URI_append_sota = "file://uEnv-ota.txt"
12
13do_deploy() {
14 install -d ${DEPLOYDIR}/${PN}
15}
16
17do_deploy_append_sota() {
18 install -m 0755 ${WORKDIR}/uEnv-ota.txt ${DEPLOYDIR}/${PN}/uEnv.txt
19}
20
21addtask deploy before do_package after do_install
22do_deploy[dirs] += "${DEPLOYDIR}/${PN}"
23
24PACKAGE_ARCH = "${MACHINE_ARCH}"
25