summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/sota_none.bbclass6
-rw-r--r--conf/distro/sota.conf.inc3
-rw-r--r--recipes-support/glib-networking/glib-networking_%.bbappend7
-rw-r--r--recipes-support/libsoup/libsoup-2.4_%.bbappend2
4 files changed, 13 insertions, 5 deletions
diff --git a/classes/sota_none.bbclass b/classes/sota_none.bbclass
index 86eaf0b..c11b070 100644
--- a/classes/sota_none.bbclass
+++ b/classes/sota_none.bbclass
@@ -1,4 +1,4 @@
1# null machine it's here to make bitbake happy when SOTA_MACHINE is undefined 1# null machine it's here to make bitbake happy when SOTA_MACHINE is undefined
2python __anonymous() { 2#python __anonymous() {
3 bb.warn("SOTA functionality is not yet supported for your machine") 3# bb.warn("SOTA functionality is not yet supported for your machine")
4} 4#}
diff --git a/conf/distro/sota.conf.inc b/conf/distro/sota.conf.inc
index 07844e3..1775d92 100644
--- a/conf/distro/sota.conf.inc
+++ b/conf/distro/sota.conf.inc
@@ -5,7 +5,10 @@
5# require conf/distro/sota.conf.inc 5# require conf/distro/sota.conf.inc
6 6
7DISTRO_FEATURES_append = " sota" 7DISTRO_FEATURES_append = " sota"
8DISTRO_FEATURES_NATIVE_append = " sota"
8INHERIT += " sota" 9INHERIT += " sota"
9SOTA_CLIENT ?= "aktualizr" 10SOTA_CLIENT ?= "aktualizr"
10# Prelinking increases the size of downloads and causes build errors 11# Prelinking increases the size of downloads and causes build errors
11USER_CLASSES_remove = "image-prelink" 12USER_CLASSES_remove = "image-prelink"
13
14HOSTTOOLS_append = " sync sha256sum"
diff --git a/recipes-support/glib-networking/glib-networking_%.bbappend b/recipes-support/glib-networking/glib-networking_%.bbappend
index fccb949..1c4fe19 100644
--- a/recipes-support/glib-networking/glib-networking_%.bbappend
+++ b/recipes-support/glib-networking/glib-networking_%.bbappend
@@ -1 +1,6 @@
1BBCLASSEXTEND_append_sota = " native" 1BBCLASSEXTEND_append_sota = " native nativesdk"
2
3# Hackery to prevent relocatable_native_pcfiles from crashing
4do_install_append_class-native () {
5 rmdir ${D}${libdir}/pkgconfig
6}
diff --git a/recipes-support/libsoup/libsoup-2.4_%.bbappend b/recipes-support/libsoup/libsoup-2.4_%.bbappend
index ce4df6d..18383f1 100644
--- a/recipes-support/libsoup/libsoup-2.4_%.bbappend
+++ b/recipes-support/libsoup/libsoup-2.4_%.bbappend
@@ -1,3 +1,3 @@
1BBCLASSEXTEND_append_sota = " native" 1BBCLASSEXTEND_append_sota = " native nativesdk"
2 2
3DEPENDS_append_class-native = "${@bb.utils.contains('DISTRO_FEATURES', 'sota', ' glib-networking-native', ' ', d)}" 3DEPENDS_append_class-native = "${@bb.utils.contains('DISTRO_FEATURES', 'sota', ' glib-networking-native', ' ', d)}"