summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/image_types_ostree.bbclass3
-rw-r--r--conf/distro/sota.conf.inc3
-rw-r--r--recipes-bsp/u-boot/u-boot_2016.11.bb9
-rw-r--r--recipes-sota/ostree/ostree_git.bb4
-rw-r--r--recipes-support/glib-networking/glib-networking_%.bbappend7
-rw-r--r--recipes-support/libsoup/libsoup-2.4_%.bbappend2
-rw-r--r--scripts/lib/wic/plugins/source/otaimage.py11
7 files changed, 29 insertions, 10 deletions
diff --git a/classes/image_types_ostree.bbclass b/classes/image_types_ostree.bbclass
index 8c9f262..110f88d 100644
--- a/classes/image_types_ostree.bbclass
+++ b/classes/image_types_ostree.bbclass
@@ -6,7 +6,8 @@ IMAGE_DEPENDS_ostree = "ostree-native:do_populate_sysroot \
6 openssl-native:do_populate_sysroot \ 6 openssl-native:do_populate_sysroot \
7 zip-native:do_populate_sysroot \ 7 zip-native:do_populate_sysroot \
8 virtual/kernel:do_deploy \ 8 virtual/kernel:do_deploy \
9 ${OSTREE_INITRAMFS_IMAGE}:do_image_complete" 9 ${OSTREE_INITRAMFS_IMAGE}:do_image_complete \
10 unzip-native"
10 11
11export OSTREE_REPO 12export OSTREE_REPO
12export OSTREE_BRANCHNAME 13export OSTREE_BRANCHNAME
diff --git a/conf/distro/sota.conf.inc b/conf/distro/sota.conf.inc
index 7438424..ea1ca95 100644
--- a/conf/distro/sota.conf.inc
+++ b/conf/distro/sota.conf.inc
@@ -5,6 +5,9 @@
5# require conf/distro/sota.conf.inc 5# require conf/distro/sota.conf.inc
6 6
7DISTRO_FEATURES_append = " sota" 7DISTRO_FEATURES_append = " sota"
8DISTRO_FEATURES_NATIVE_append = " sota"
8INHERIT += " sota" 9INHERIT += " sota"
9# Prelinking increases the size of downloads and causes build errors 10# Prelinking increases the size of downloads and causes build errors
10USER_CLASSES_remove = "image-prelink" 11USER_CLASSES_remove = "image-prelink"
12
13HOSTTOOLS_append = " sync sha256sum"
diff --git a/recipes-bsp/u-boot/u-boot_2016.11.bb b/recipes-bsp/u-boot/u-boot_2016.11.bb
index e6e1fcf..acd4bb8 100644
--- a/recipes-bsp/u-boot/u-boot_2016.11.bb
+++ b/recipes-bsp/u-boot/u-boot_2016.11.bb
@@ -1,8 +1,17 @@
1require recipes-bsp/u-boot/u-boot.inc 1require recipes-bsp/u-boot/u-boot.inc
2 2
3HOMEPAGE = "http://www.denx.de/wiki/U-Boot/WebHome"
4SECTION = "bootloaders"
5
6LICENSE = "GPLv2+"
7LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6"
8PE = "1"
9
3DEPENDS += "dtc-native" 10DEPENDS += "dtc-native"
4 11
5SRCREV = "5ea3e51fc481613a8dee8c02848d1b42c81ad892" 12SRCREV = "5ea3e51fc481613a8dee8c02848d1b42c81ad892"
13SRC_URI = "git://git.denx.de/u-boot.git"
14S = "${WORKDIR}/git"
6 15
7PV = "v2016.11+git${SRCPV}" 16PV = "v2016.11+git${SRCPV}"
8 17
diff --git a/recipes-sota/ostree/ostree_git.bb b/recipes-sota/ostree/ostree_git.bb
index 84e86e2..8937e5e 100644
--- a/recipes-sota/ostree/ostree_git.bb
+++ b/recipes-sota/ostree/ostree_git.bb
@@ -16,11 +16,11 @@ S = "${WORKDIR}/git"
16 16
17BBCLASSEXTEND = "native" 17BBCLASSEXTEND = "native"
18 18
19DEPENDS += "attr libarchive glib-2.0 pkgconfig gpgme libgsystem fuse libsoup-2.4 e2fsprogs gtk-doc-native curl" 19DEPENDS += "attr libarchive glib-2.0 pkgconfig gpgme libgsystem fuse libsoup-2.4 e2fsprogs gtk-doc-native curl xz"
20DEPENDS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', ' systemd', '', d)}" 20DEPENDS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', ' systemd', '', d)}"
21DEPENDS_remove_class-native = "systemd-native" 21DEPENDS_remove_class-native = "systemd-native"
22 22
23RDEPENDS_${PN} = "python util-linux-libuuid util-linux-libblkid util-linux-libmount libcap xz bash" 23RDEPENDS_${PN} = "python util-linux-libuuid util-linux-libblkid util-linux-libmount libcap bash"
24RDEPENDS_${PN}_remove_class-native = "python-native" 24RDEPENDS_${PN}_remove_class-native = "python-native"
25 25
26EXTRA_OECONF = "--with-libarchive --disable-gtk-doc --disable-gtk-doc-html --disable-gtk-doc-pdf --disable-man --with-smack --with-builtin-grub2-mkconfig --with-curl" 26EXTRA_OECONF = "--with-libarchive --disable-gtk-doc --disable-gtk-doc-html --disable-gtk-doc-pdf --disable-man --with-smack --with-builtin-grub2-mkconfig --with-curl"
diff --git a/recipes-support/glib-networking/glib-networking_%.bbappend b/recipes-support/glib-networking/glib-networking_%.bbappend
index fccb949..1c4fe19 100644
--- a/recipes-support/glib-networking/glib-networking_%.bbappend
+++ b/recipes-support/glib-networking/glib-networking_%.bbappend
@@ -1 +1,6 @@
1BBCLASSEXTEND_append_sota = " native" 1BBCLASSEXTEND_append_sota = " native nativesdk"
2
3# Hackery to prevent relocatable_native_pcfiles from crashing
4do_install_append_class-native () {
5 rmdir ${D}${libdir}/pkgconfig
6}
diff --git a/recipes-support/libsoup/libsoup-2.4_%.bbappend b/recipes-support/libsoup/libsoup-2.4_%.bbappend
index ce4df6d..18383f1 100644
--- a/recipes-support/libsoup/libsoup-2.4_%.bbappend
+++ b/recipes-support/libsoup/libsoup-2.4_%.bbappend
@@ -1,3 +1,3 @@
1BBCLASSEXTEND_append_sota = " native" 1BBCLASSEXTEND_append_sota = " native nativesdk"
2 2
3DEPENDS_append_class-native = "${@bb.utils.contains('DISTRO_FEATURES', 'sota', ' glib-networking-native', ' ', d)}" 3DEPENDS_append_class-native = "${@bb.utils.contains('DISTRO_FEATURES', 'sota', ' glib-networking-native', ' ', d)}"
diff --git a/scripts/lib/wic/plugins/source/otaimage.py b/scripts/lib/wic/plugins/source/otaimage.py
index dc507a8..eef0bb4 100644
--- a/scripts/lib/wic/plugins/source/otaimage.py
+++ b/scripts/lib/wic/plugins/source/otaimage.py
@@ -15,11 +15,12 @@
15# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA. 15# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
16# 16#
17 17
18import logging
18import os 19import os
20import sys
19 21
20from wic import msger
21from wic.pluginbase import SourcePlugin 22from wic.pluginbase import SourcePlugin
22from wic.utils.oe.misc import get_bitbake_var 23from wic.utils.misc import get_bitbake_var
23 24
24class OTAImagePlugin(SourcePlugin): 25class OTAImagePlugin(SourcePlugin):
25 """ 26 """
@@ -57,12 +58,12 @@ class OTAImagePlugin(SourcePlugin):
57 """ 58 """
58 bootimg_dir = get_bitbake_var("DEPLOY_DIR_IMAGE") 59 bootimg_dir = get_bitbake_var("DEPLOY_DIR_IMAGE")
59 if not bootimg_dir: 60 if not bootimg_dir:
60 msger.error("Couldn't find DEPLOY_DIR_IMAGE, exiting\n") 61 logger.error("Couldn't find DEPLOY_DIR_IMAGE, exiting\n")
61 62
62 msger.debug('Bootimg dir: %s' % bootimg_dir) 63 logger.debug('Bootimg dir: %s' % bootimg_dir)
63 64
64 src = bootimg_dir + "/" + get_bitbake_var("IMAGE_LINK_NAME") + ".otaimg" 65 src = bootimg_dir + "/" + get_bitbake_var("IMAGE_LINK_NAME") + ".otaimg"
65 66
66 msger.debug('Preparing partition using image %s' % (src)) 67 logger.debug('Preparing partition using image %s' % (src))
67 part.prepare_rootfs_from_fs_image(cr_workdir, src, "") 68 part.prepare_rootfs_from_fs_image(cr_workdir, src, "")
68 69