summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-core/images/initramfs-ostree-image.bb1
-rw-r--r--recipes-sota/rvi-sota-client/rvi-sota-client.inc5
-rwxr-xr-xscripts/envsetup.sh10
3 files changed, 13 insertions, 3 deletions
diff --git a/recipes-core/images/initramfs-ostree-image.bb b/recipes-core/images/initramfs-ostree-image.bb
index cd872b8..4870579 100644
--- a/recipes-core/images/initramfs-ostree-image.bb
+++ b/recipes-core/images/initramfs-ostree-image.bb
@@ -24,6 +24,7 @@ IMAGE_ROOTFS_SIZE = "8192"
24# Users will often ask for extra space in their rootfs by setting this 24# Users will often ask for extra space in their rootfs by setting this
25# globally. Since this is a initramfs, we don't want to make it bigger 25# globally. Since this is a initramfs, we don't want to make it bigger
26IMAGE_ROOTFS_EXTRA_SPACE = "0" 26IMAGE_ROOTFS_EXTRA_SPACE = "0"
27IMAGE_OVERHEAD_FACTOR = "1.0"
27 28
28BAD_RECOMMENDATIONS += "busybox-syslog" 29BAD_RECOMMENDATIONS += "busybox-syslog"
29 30
diff --git a/recipes-sota/rvi-sota-client/rvi-sota-client.inc b/recipes-sota/rvi-sota-client/rvi-sota-client.inc
index 00709af..6718bab 100644
--- a/recipes-sota/rvi-sota-client/rvi-sota-client.inc
+++ b/recipes-sota/rvi-sota-client/rvi-sota-client.inc
@@ -13,11 +13,12 @@ SRC_URI[index.md5sum] = "6a635e8a081b4d4ba4cebffd721c2d7d"
13SRC_URI[index.sha256sum] = "1913c41d4b8de89a931b6f9e418f83e70a083e12e6c247e8510ee932571ebae2" 13SRC_URI[index.sha256sum] = "1913c41d4b8de89a931b6f9e418f83e70a083e12e6c247e8510ee932571ebae2"
14 14
15# also update PV and SRC_URI crates when updating SRCREV 15# also update PV and SRC_URI crates when updating SRCREV
16SRCREV = "5b335cd46c5848d8012ef03f06b50a63fdac4f7c" 16SRCREV = "d41540a54ee7bba20835b337f3a477d5f1386c76"
17
17PR = "1" 18PR = "1"
18 19
19# generate with: `make package-version` 20# generate with: `make package-version`
20PV = "0.2.33-66-g5b335cd" 21PV = "0.2.33-76-gd41540a"
21 22
22# generate with: `make yocto-version` 23# generate with: `make yocto-version`
23SRC_URI = " \ 24SRC_URI = " \
diff --git a/scripts/envsetup.sh b/scripts/envsetup.sh
index ff78681..260b048 100755
--- a/scripts/envsetup.sh
+++ b/scripts/envsetup.sh
@@ -24,7 +24,15 @@ fi
24METADIR="${SOURCEDIR}/../.." 24METADIR="${SOURCEDIR}/../.."
25 25
26if [[ ! -f "${BUILDDIR}/conf/local.conf" ]]; then 26if [[ ! -f "${BUILDDIR}/conf/local.conf" ]]; then
27 source "$METADIR/poky/oe-init-build-env" "$BUILDDIR" 27 if [ -z "$TEMPLATECONF" ] && [ -d ${METADIR}/meta-updater-${MACHINE}/conf ]; then
28 # Use the template configurations for the specified machine
29 TEMPLATECONF=${METADIR}/meta-updater-${MACHINE}/conf
30 source "$METADIR/poky/oe-init-build-env" "$BUILDDIR"
31 unset TEMPLATECONF
32 else
33 # Use the default configurations or TEMPLATECONF set by the user
34 source "$METADIR/poky/oe-init-build-env" "$BUILDDIR"
35 fi
28 echo "METADIR := \"\${@os.path.abspath('${METADIR}')}\"" >> conf/bblayers.conf 36 echo "METADIR := \"\${@os.path.abspath('${METADIR}')}\"" >> conf/bblayers.conf
29 cat "${METADIR}/meta-updater/conf/include/bblayers/sota.inc" >> conf/bblayers.conf 37 cat "${METADIR}/meta-updater/conf/include/bblayers/sota.inc" >> conf/bblayers.conf
30 cat "${METADIR}/meta-updater/conf/include/bblayers/sota_${MACHINE}.inc" >> conf/bblayers.conf 38 cat "${METADIR}/meta-updater/conf/include/bblayers/sota_${MACHINE}.inc" >> conf/bblayers.conf