summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/image_types_ostree.bbclass6
-rw-r--r--classes/image_types_ota.bbclass8
-rw-r--r--recipes-support/libp11/libp11_0.4.9.bb (renamed from recipes-support/libp11/libp11_0.4.7.bb)10
3 files changed, 16 insertions, 8 deletions
diff --git a/classes/image_types_ostree.bbclass b/classes/image_types_ostree.bbclass
index b525738..a5d43dc 100644
--- a/classes/image_types_ostree.bbclass
+++ b/classes/image_types_ostree.bbclass
@@ -32,6 +32,12 @@ IMAGE_CMD_ostree () {
32 32
33 cd ${OSTREE_ROOTFS} 33 cd ${OSTREE_ROOTFS}
34 34
35 for d in var/*; do
36 if [ "${d}" != "var/local" ]; then
37 rm -rf ${d}
38 fi
39 done
40
35 # Create sysroot directory to which physical sysroot will be mounted 41 # Create sysroot directory to which physical sysroot will be mounted
36 mkdir sysroot 42 mkdir sysroot
37 ln -sf sysroot/ostree ostree 43 ln -sf sysroot/ostree ostree
diff --git a/classes/image_types_ota.bbclass b/classes/image_types_ota.bbclass
index 0b2f7a1..cd58080 100644
--- a/classes/image_types_ota.bbclass
+++ b/classes/image_types_ota.bbclass
@@ -99,13 +99,15 @@ fakeroot do_otasetup () {
99 # Copy deployment /home and /var/sota to sysroot 99 # Copy deployment /home and /var/sota to sysroot
100 HOME_TMP=`mktemp -d ${WORKDIR}/home-tmp-XXXXX` 100 HOME_TMP=`mktemp -d ${WORKDIR}/home-tmp-XXXXX`
101 101
102 tar --xattrs --xattrs-include='*' -C ${HOME_TMP} -xf ${DEPLOY_DIR_IMAGE}/${IMAGE_LINK_NAME}.rootfs.ostree.tar.bz2 ./usr/homedirs ./var/sota ./var/local || true 102 tar --xattrs --xattrs-include='*' -C ${HOME_TMP} -xf ${DEPLOY_DIR_IMAGE}/${IMAGE_LINK_NAME}.rootfs.ostree.tar.bz2 ./usr/homedirs ./var/local || true
103 mv ${HOME_TMP}/var/sota ${OTA_SYSROOT}/ostree/deploy/${OSTREE_OSNAME}/var/ || true 103
104 mv ${HOME_TMP}/var/local ${OTA_SYSROOT}/ostree/deploy/${OSTREE_OSNAME}/var/ || true 104 cp -a ${IMAGE_ROOTFS}/var/sota ${OTA_SYSROOT}/ostree/deploy/${OSTREE_OSNAME}/var/ || true
105 # Create /var/sota if it doesn't exist yet 105 # Create /var/sota if it doesn't exist yet
106 mkdir -p ${OTA_SYSROOT}/ostree/deploy/${OSTREE_OSNAME}/var/sota || true 106 mkdir -p ${OTA_SYSROOT}/ostree/deploy/${OSTREE_OSNAME}/var/sota || true
107 # Ensure the permissions are correctly set 107 # Ensure the permissions are correctly set
108 chmod 700 ${OTA_SYSROOT}/ostree/deploy/${OSTREE_OSNAME}/var/sota 108 chmod 700 ${OTA_SYSROOT}/ostree/deploy/${OSTREE_OSNAME}/var/sota
109
110 mv ${HOME_TMP}/var/local ${OTA_SYSROOT}/ostree/deploy/${OSTREE_OSNAME}/var/ || true
109 mv ${HOME_TMP}/usr/homedirs/home ${OTA_SYSROOT}/ || true 111 mv ${HOME_TMP}/usr/homedirs/home ${OTA_SYSROOT}/ || true
110 # Ensure that /var/local exists (AGL symlinks /usr/local to /var/local) 112 # Ensure that /var/local exists (AGL symlinks /usr/local to /var/local)
111 install -d ${OTA_SYSROOT}/ostree/deploy/${OSTREE_OSNAME}/var/local 113 install -d ${OTA_SYSROOT}/ostree/deploy/${OSTREE_OSNAME}/var/local
diff --git a/recipes-support/libp11/libp11_0.4.7.bb b/recipes-support/libp11/libp11_0.4.9.bb
index 02d9e50..6d0165f 100644
--- a/recipes-support/libp11/libp11_0.4.7.bb
+++ b/recipes-support/libp11/libp11_0.4.9.bb
@@ -11,14 +11,14 @@ RDEPENDS_${PN} += " opensc"
11 11
12SRC_URI = "git://github.com/OpenSC/libp11.git \ 12SRC_URI = "git://github.com/OpenSC/libp11.git \
13 file://0001-Workaround-for-a-buggy-version-of-openssl-1.0.2m.patch" 13 file://0001-Workaround-for-a-buggy-version-of-openssl-1.0.2m.patch"
14SRCREV = "da725ab727342083478150a203a3c80c4551feb4" 14SRCREV = "e1210903291b1de9eabcad26e740a4b2fbcca692"
15 15
16S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
17 17
18inherit autotools pkgconfig 18inherit autotools pkgconfig
19 19
20# Currently, Makefile dependencies are incorrectly defined which causes build errors 20# Currently, Makefile dependencies are incorrectly defined which causes build errors
21# The number of jobs is high 21# if the number of jobs is high
22# See https://github.com/OpenSC/libp11/issues/94 22# See https://github.com/OpenSC/libp11/issues/94
23PARALLEL_MAKE = "" 23PARALLEL_MAKE = ""
24EXTRA_OECONF = "--disable-static" 24EXTRA_OECONF = "--disable-static"
@@ -28,12 +28,12 @@ do_install_append () {
28 rm -rf ${D}${docdir}/${BPN} 28 rm -rf ${D}${docdir}/${BPN}
29} 29}
30 30
31FILES_${PN} = "${libdir}/engines/pkcs11.so \ 31FILES_${PN} = "${libdir}/engines*/pkcs11.so \
32 ${libdir}/engines/libpkcs11${SOLIBS} \ 32 ${libdir}/engines*/libpkcs11${SOLIBS} \
33 ${libdir}/libp11${SOLIBS}" 33 ${libdir}/libp11${SOLIBS}"
34 34
35FILES_${PN}-dev = " \ 35FILES_${PN}-dev = " \
36 ${libdir}/engines/libpkcs11${SOLIBSDEV} \ 36 ${libdir}/engines*/libpkcs11${SOLIBSDEV} \
37 ${libdir}/libp11${SOLIBSDEV} \ 37 ${libdir}/libp11${SOLIBSDEV} \
38 ${libdir}/pkgconfig/libp11.pc \ 38 ${libdir}/pkgconfig/libp11.pc \
39 /usr/include" 39 /usr/include"