summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-sota/rvi-sota-client/rvi-sota-client_git.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb b/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb
index d04ea88..20c32cd 100644
--- a/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb
+++ b/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb
@@ -112,6 +112,8 @@ RDEPENDS_${PN} = " libcrypto \
112 lshw \ 112 lshw \
113 jq \ 113 jq \
114 " 114 "
115export SOTA_VERSION = "${PV}"
116
115do_compile_prepend() { 117do_compile_prepend() {
116 # Fetch and build the specific build of hyper that is specified in cargo.toml. 118 # Fetch and build the specific build of hyper that is specified in cargo.toml.
117 # meta-rust doesn't support fetching crates that don't point to a specific tag 119 # meta-rust doesn't support fetching crates that don't point to a specific tag
@@ -134,6 +136,5 @@ do_install() {
134 install -c ${S}/run/sota_client.service ${D}${systemd_unitdir}/system 136 install -c ${S}/run/sota_client.service ${D}${systemd_unitdir}/system
135 137
136 install -d ${D}${sysconfdir} 138 install -d ${D}${sysconfdir}
137 echo `git log -1 --pretty=format:%H` > ${D}${sysconfdir}/sota_client.version
138 install -c ${S}/run/sota_certificates ${D}${sysconfdir} 139 install -c ${S}/run/sota_certificates ${D}${sysconfdir}
139} 140}