diff options
-rw-r--r-- | classes/image_types_ota.bbclass | 23 | ||||
-rw-r--r-- | conf/machine/qemux86-ota.conf | 37 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot-ota/0001-Set-up-environment-for-OSTree-integration.patch (renamed from recipes-bsp/u-boot/u-boot-buildrom/0001-Set-up-environment-for-OSTree-integration.patch) | 0 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot-ota_2016.07.bb (renamed from recipes-bsp/u-boot/u-boot-buildrom_2016.07.bb) | 9 |
4 files changed, 21 insertions, 48 deletions
diff --git a/classes/image_types_ota.bbclass b/classes/image_types_ota.bbclass index a67cc80..9820724 100644 --- a/classes/image_types_ota.bbclass +++ b/classes/image_types_ota.bbclass | |||
@@ -1,6 +1,6 @@ | |||
1 | # Image to use with u-boot as BIOS and OSTree deployment system | 1 | # Image to use with u-boot as BIOS and OSTree deployment system |
2 | 2 | ||
3 | inherit image_types | 3 | #inherit image_types |
4 | 4 | ||
5 | # Boot filesystem size in MiB | 5 | # Boot filesystem size in MiB |
6 | # OSTree updates may require some space on boot file system for | 6 | # OSTree updates may require some space on boot file system for |
@@ -9,12 +9,15 @@ inherit image_types | |||
9 | BOOTFS_EXTRA_SIZE ?= "512" | 9 | BOOTFS_EXTRA_SIZE ?= "512" |
10 | export BOOTFS_EXTRA_SIZE | 10 | export BOOTFS_EXTRA_SIZE |
11 | 11 | ||
12 | IMAGE_TYPES += " otaimg" | 12 | do_otaimg[depends] += "e2fsprogs-native:do_populate_sysroot \ |
13 | IMAGE_DEPENDS_ota = "e2fsprogs-native \ | 13 | parted-native:do_populate_sysroot \ |
14 | virtual/bootloader \ | 14 | virtual/kernel:do_deploy \ |
15 | virtual/kernel \ | 15 | ${INITRD_IMAGE}:do_rootfs \ |
16 | parted-native \ | 16 | ${PN}:do_rootfs" |
17 | ${INITRD_IMAGE}" | 17 | |
18 | ROOTFS ?= "${DEPLOY_DIR_IMAGE}/${IMAGE_BASENAME}-${MACHINE}.ext4" | ||
19 | INITRD_IMAGE ?= "core-image-minimal-initramfs" | ||
20 | INITRD ?= "${DEPLOY_DIR_IMAGE}/${INITRD_IMAGE}-${MACHINE}.cpio.gz" | ||
18 | 21 | ||
19 | build_bootfs () { | 22 | build_bootfs () { |
20 | KERNEL_FILE=${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE} | 23 | KERNEL_FILE=${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE} |
@@ -36,7 +39,7 @@ build_bootfs () { | |||
36 | rm -rf $BOOTTMP | 39 | rm -rf $BOOTTMP |
37 | } | 40 | } |
38 | 41 | ||
39 | IMAGE_CMD_otaimg () { | 42 | do_otaimg () { |
40 | BOOTIMG=${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.otaboot.ext4 | 43 | BOOTIMG=${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.otaboot.ext4 |
41 | rm -f $BOOTIMG | 44 | rm -f $BOOTIMG |
42 | build_bootfs $BOOTIMG | 45 | build_bootfs $BOOTIMG |
@@ -70,4 +73,8 @@ IMAGE_CMD_otaimg () { | |||
70 | ln -s ${IMAGE_NAME}.otaimg ${IMAGE_LINK_NAME}.otaimg | 73 | ln -s ${IMAGE_NAME}.otaimg ${IMAGE_LINK_NAME}.otaimg |
71 | } | 74 | } |
72 | 75 | ||
76 | addtask otaimg before do_build | ||
77 | |||
78 | IMAGE_TYPES += " otaimg" | ||
79 | IMAGE_TYPES_MASKED += "otaimg" | ||
73 | IMAGE_TYPEDEP_otaimg = "ext4" | 80 | IMAGE_TYPEDEP_otaimg = "ext4" |
diff --git a/conf/machine/qemux86-ota.conf b/conf/machine/qemux86-ota.conf deleted file mode 100644 index 3c58870..0000000 --- a/conf/machine/qemux86-ota.conf +++ /dev/null | |||
@@ -1,37 +0,0 @@ | |||
1 | #@TYPE: Machine | ||
2 | #@NAME: common_pc | ||
3 | #@DESCRIPTION: Machine configuration for running a common x86 | ||
4 | |||
5 | PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xorg" | ||
6 | PREFERRED_PROVIDER_virtual/libgl ?= "mesa" | ||
7 | PREFERRED_PROVIDER_virtual/libgles1 ?= "mesa" | ||
8 | PREFERRED_PROVIDER_virtual/libgles2 ?= "mesa" | ||
9 | |||
10 | require conf/machine/include/qemu.inc | ||
11 | require conf/machine/include/tune-i586.inc | ||
12 | |||
13 | KERNEL_IMAGETYPE = "bzImage" | ||
14 | |||
15 | PREFERRED_PROVIDER_virtual/bootloader = "u-boot-buildrom" | ||
16 | UBOOT_MACHINE = "qemu-x86_defconfig" | ||
17 | |||
18 | IMAGE_CLASSES += "image_types_ota" | ||
19 | IMAGE_FSTYPES += "otaimg" | ||
20 | |||
21 | SERIAL_CONSOLES = "115200;ttyS0 115200;ttyS1" | ||
22 | |||
23 | XSERVER = "xserver-xorg \ | ||
24 | ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'mesa-driver-swrast xserver-xorg-extension-glx', '', d)} \ | ||
25 | xf86-input-vmmouse \ | ||
26 | xf86-input-keyboard \ | ||
27 | xf86-input-evdev \ | ||
28 | xf86-video-cirrus \ | ||
29 | xf86-video-fbdev \ | ||
30 | xf86-video-vmware" | ||
31 | |||
32 | MACHINE_FEATURES += "x86" | ||
33 | |||
34 | MACHINE_ESSENTIAL_EXTRA_RDEPENDS += "v86d" | ||
35 | |||
36 | MACHINEOVERRIDES .= ":qemux86" | ||
37 | KMACHINE = "qemux86" | ||
diff --git a/recipes-bsp/u-boot/u-boot-buildrom/0001-Set-up-environment-for-OSTree-integration.patch b/recipes-bsp/u-boot/u-boot-ota/0001-Set-up-environment-for-OSTree-integration.patch index c33d40c..c33d40c 100644 --- a/recipes-bsp/u-boot/u-boot-buildrom/0001-Set-up-environment-for-OSTree-integration.patch +++ b/recipes-bsp/u-boot/u-boot-ota/0001-Set-up-environment-for-OSTree-integration.patch | |||
diff --git a/recipes-bsp/u-boot/u-boot-buildrom_2016.07.bb b/recipes-bsp/u-boot/u-boot-ota_2016.07.bb index 7e3c67f..8f0b20a 100644 --- a/recipes-bsp/u-boot/u-boot-buildrom_2016.07.bb +++ b/recipes-bsp/u-boot/u-boot-ota_2016.07.bb | |||
@@ -13,7 +13,10 @@ SRC_URI += "file://0001-Set-up-environment-for-OSTree-integration.patch" | |||
13 | 13 | ||
14 | PV = "v2016.07+git${SRCPV}" | 14 | PV = "v2016.07+git${SRCPV}" |
15 | 15 | ||
16 | EXTRA_OEMAKE_append = " KCFLAGS=-fgnu89-inline BUILD_ROM=y" | 16 | EXTRA_OEMAKE_append = " KCFLAGS=-fgnu89-inline" |
17 | 17 | EXTRA_OEMAKE_append_qemux86 = " KCFLAGS=-fgnu89-inline BUILD_ROM=y" | |
18 | UBOOT_SUFFIX = "rom" | 18 | EXTRA_OEMAKE_append_qemux86-64 = " KCFLAGS=-fgnu89-inline BUILD_ROM=y" |
19 | 19 | ||
20 | UBOOT_SUFFIX = "bin" | ||
21 | UBOOT_SUFFIX_qemux86 = "rom" | ||
22 | UBOOT_SUFFIX_qemux86-64 = "rom" | ||