diff options
7 files changed, 61 insertions, 48 deletions
diff --git a/conf/local.conf.sample.append b/conf/local.conf.sample.append new file mode 100644 index 0000000..4588ec3 --- /dev/null +++ b/conf/local.conf.sample.append | |||
@@ -0,0 +1,35 @@ | |||
1 | |||
2 | # | ||
3 | # meta-updater configuration, see README.adoc and aktualizr's | ||
4 | # documentation for more options and detailed documentation | ||
5 | # | ||
6 | |||
7 | MACHINE = "##MACHINE##" | ||
8 | DISTRO = "poky-sota-systemd" | ||
9 | |||
10 | # General SOTA setup | ||
11 | #SOTA_CLIENT_PROV = "aktualizr-auto-prov" | ||
12 | #SOTA_PACKED_CREDENTIALS = "/path/to/credentials.zip" | ||
13 | |||
14 | # Uncomment this line to start an ssh server at boot automatically | ||
15 | #IMAGE_FEATURES += "ssh-server-dropbear" | ||
16 | |||
17 | # Uncomment this line to set the log level of aktualizr to 'debug' (from 'info' | ||
18 | # by default) | ||
19 | #IMAGE_INSTALL_append += " aktualizr-log-debug" | ||
20 | |||
21 | # Store systemd logs in persistent storage | ||
22 | # | ||
23 | # It greatly helps diagnosing issues on testing devices but should be | ||
24 | # carefully weighted against file system usage and flash device wear for | ||
25 | # production systems. Please refer to systemd's docs for more details | ||
26 | IMAGE_INSTALL_append += " systemd-journald-persistent" | ||
27 | |||
28 | # Set resource limits for aktualizr service | ||
29 | # | ||
30 | # Uncomment these lines to change the default parameters. | ||
31 | # | ||
32 | #RESOURCE_CPU_WEIGHT_pn-aktualizr = "100" | ||
33 | #RESOURCE_MEMORY_HIGH_pn-aktualizr = "100M" | ||
34 | #RESOURCE_MEMORY_MAX_pn-aktualizr = "80%" | ||
35 | IMAGE_INSTALL_append += " aktualizr-resource-control" | ||
diff --git a/recipes-support/python-canonicaljson/python-canonicaljson.bb b/recipes-support/python-canonicaljson/python-canonicaljson.bb deleted file mode 100644 index d8a0728..0000000 --- a/recipes-support/python-canonicaljson/python-canonicaljson.bb +++ /dev/null | |||
@@ -1,18 +0,0 @@ | |||
1 | DESCRIPTION = "python-canonicaljson recipe" | ||
2 | |||
3 | LICENSE = "Apache-2.0" | ||
4 | LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=2ee41112a44fe7014dce33e26468ba93" | ||
5 | |||
6 | SRCREV = "92e2c06871cc275c2a8b8e3e899141a212aae0e8" | ||
7 | SRC_URI = "git://github.com/matrix-org/python-canonicaljson.git" | ||
8 | S = "${WORKDIR}/git" | ||
9 | |||
10 | # Generate with: | ||
11 | # git describe --tags | cut -b2- | ||
12 | PV = "1.0.0" | ||
13 | inherit setuptools | ||
14 | |||
15 | RDEPENDS_${PN} = "\ | ||
16 | python-simplejson \ | ||
17 | python-frozendict \ | ||
18 | " | ||
diff --git a/recipes-support/python-frozendict/python-frozendict.bb b/recipes-support/python-frozendict/python-frozendict.bb deleted file mode 100644 index 79fe5c8..0000000 --- a/recipes-support/python-frozendict/python-frozendict.bb +++ /dev/null | |||
@@ -1,12 +0,0 @@ | |||
1 | DESCRIPTION = "python-frozendict recipe" | ||
2 | |||
3 | LICENSE = "BSD" | ||
4 | LIC_FILES_CHKSUM = "file://${S}/LICENSE.txt;md5=f4da037a49c09b456fdbbc7a5bd36132" | ||
5 | |||
6 | SRCREV = "c5d16bafcca7b72ff3e8f40d3a9081e4c9233f1b" | ||
7 | SRC_URI = "git://github.com/slezica/python-frozendict.git" | ||
8 | S = "${WORKDIR}/git" | ||
9 | |||
10 | PV = "1.2" | ||
11 | inherit setuptools | ||
12 | |||
diff --git a/recipes-support/python-petname/python-petname.bb b/recipes-support/python-petname/python-petname.bb deleted file mode 100644 index 9abd5d9..0000000 --- a/recipes-support/python-petname/python-petname.bb +++ /dev/null | |||
@@ -1,16 +0,0 @@ | |||
1 | DESCRIPTION = "python-petname recipe" | ||
2 | |||
3 | LICENSE = "Apache-2.0" | ||
4 | LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" | ||
5 | |||
6 | SRCREV = "d0b767cdb1567defb104f29c3fd022239a7f231e" | ||
7 | SRC_URI = "git://github.com/dustinkirkland/python-petname.git" | ||
8 | S = "${WORKDIR}/git" | ||
9 | |||
10 | PV = "2.2" | ||
11 | inherit setuptools | ||
12 | RDEPENDS_${PN} = " python-setuptools \ | ||
13 | python-argparse \ | ||
14 | " | ||
15 | |||
16 | FILES_${PN} = "${libdir} ${bindir}/petname" | ||
diff --git a/recipes-support/systemd-journald-persistent/files/10-persistent-journal.conf b/recipes-support/systemd-journald-persistent/files/10-persistent-journal.conf new file mode 100644 index 0000000..a56527c --- /dev/null +++ b/recipes-support/systemd-journald-persistent/files/10-persistent-journal.conf | |||
@@ -0,0 +1,3 @@ | |||
1 | [Journal] | ||
2 | Storage=persistent | ||
3 | SystemMaxUse=64M | ||
diff --git a/recipes-support/systemd-journald-persistent/systemd-journald-persistent.bb b/recipes-support/systemd-journald-persistent/systemd-journald-persistent.bb new file mode 100644 index 0000000..1715fe1 --- /dev/null +++ b/recipes-support/systemd-journald-persistent/systemd-journald-persistent.bb | |||
@@ -0,0 +1,20 @@ | |||
1 | SUMMARY = "Configuration for systemd-journald" | ||
2 | DESCRIPTION = "Provides configuration for systemd-journald, so that logs are \ | ||
3 | stored on persistent storage" | ||
4 | LICENSE = "MPL-2.0" | ||
5 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7f619bab123dad" | ||
6 | |||
7 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
8 | |||
9 | SRC_URI_append = " file://10-persistent-journal.conf" | ||
10 | PR = "r1" | ||
11 | |||
12 | S = "${WORKDIR}" | ||
13 | |||
14 | FILES_${PN} = "${systemd_unitdir}/journald.conf.d/*" | ||
15 | |||
16 | do_install() { | ||
17 | install -d ${D}/${systemd_unitdir}/journald.conf.d | ||
18 | install -m 0644 ${WORKDIR}/10-persistent-journal.conf ${D}/${systemd_unitdir}/journald.conf.d | ||
19 | } | ||
20 | |||
diff --git a/scripts/envsetup.sh b/scripts/envsetup.sh index ff78681..6103cf6 100755 --- a/scripts/envsetup.sh +++ b/scripts/envsetup.sh | |||
@@ -25,11 +25,12 @@ METADIR="${SOURCEDIR}/../.." | |||
25 | 25 | ||
26 | if [[ ! -f "${BUILDDIR}/conf/local.conf" ]]; then | 26 | if [[ ! -f "${BUILDDIR}/conf/local.conf" ]]; then |
27 | source "$METADIR/poky/oe-init-build-env" "$BUILDDIR" | 27 | source "$METADIR/poky/oe-init-build-env" "$BUILDDIR" |
28 | |||
28 | echo "METADIR := \"\${@os.path.abspath('${METADIR}')}\"" >> conf/bblayers.conf | 29 | echo "METADIR := \"\${@os.path.abspath('${METADIR}')}\"" >> conf/bblayers.conf |
29 | cat "${METADIR}/meta-updater/conf/include/bblayers/sota.inc" >> conf/bblayers.conf | 30 | cat "${METADIR}/meta-updater/conf/include/bblayers/sota.inc" >> conf/bblayers.conf |
30 | cat "${METADIR}/meta-updater/conf/include/bblayers/sota_${MACHINE}.inc" >> conf/bblayers.conf | 31 | cat "${METADIR}/meta-updater/conf/include/bblayers/sota_${MACHINE}.inc" >> conf/bblayers.conf |
31 | echo "MACHINE = \"${MACHINE}\"" >> conf/local.conf | 32 | |
32 | echo "DISTRO = \"poky-sota-systemd\"" >> conf/local.conf | 33 | sed "s/##MACHINE##/$MACHINE/g" "${METADIR}/meta-updater/conf/local.conf.sample.append" >> conf/local.conf |
33 | else | 34 | else |
34 | source "$METADIR/poky/oe-init-build-env" "$BUILDDIR" | 35 | source "$METADIR/poky/oe-init-build-env" "$BUILDDIR" |
35 | fi | 36 | fi |