summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-connectivity/nfs-utils/nfs-utils_%.bbappend8
-rw-r--r--scripts/qemucommand.py5
2 files changed, 8 insertions, 5 deletions
diff --git a/recipes-connectivity/nfs-utils/nfs-utils_%.bbappend b/recipes-connectivity/nfs-utils/nfs-utils_%.bbappend
index 2304ab4..7cce775 100644
--- a/recipes-connectivity/nfs-utils/nfs-utils_%.bbappend
+++ b/recipes-connectivity/nfs-utils/nfs-utils_%.bbappend
@@ -1,10 +1,10 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:" 1FILESEXTRAPATHS_prepend_sota := "${THISDIR}/${BPN}:"
2 2
3SRC_URI += "file://nfs-home-mount.service" 3SRC_URI_append_sota = " file://nfs-home-mount.service"
4 4
5SYSTEMD_SERVICE_${PN} += "nfs-home-mount.service" 5SYSTEMD_SERVICE_${PN}_append_sota = " nfs-home-mount.service"
6 6
7CONFFILES_${PN}-client += "${localstatedir}/local/lib" 7CONFFILES_${PN}-client_append_sota = " ${localstatedir}/local/lib"
8 8
9do_install_append_sota () { 9do_install_append_sota () {
10 install -d ${D}${localstatedir}/local 10 install -d ${D}${localstatedir}/local
diff --git a/scripts/qemucommand.py b/scripts/qemucommand.py
index 30929ac..9658fcd 100644
--- a/scripts/qemucommand.py
+++ b/scripts/qemucommand.py
@@ -75,7 +75,10 @@ class QemuCommand(object):
75 if args.efi: 75 if args.efi:
76 self.bios = 'OVMF.fd' 76 self.bios = 'OVMF.fd'
77 elif self.enable_u_boot: 77 elif self.enable_u_boot:
78 uboot_path = abspath(join(args.dir, self.machine, 'u-boot-qemux86-64.rom')) 78 if args.bootloader:
79 uboot_path = args.bootloader
80 else:
81 uboot_path = abspath(join(args.dir, self.machine, 'u-boot-qemux86-64.rom'))
79 if self.overlay: 82 if self.overlay:
80 new_uboot_path = self.overlay + '.u-boot.rom' 83 new_uboot_path = self.overlay + '.u-boot.rom'
81 if not exists(self.overlay): 84 if not exists(self.overlay):