summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-sota/aktualizr/aktualizr_git.bb8
-rw-r--r--recipes-test/demo-config/files/30-ostree-pacman.toml2
-rw-r--r--recipes-test/demo-config/files/30-pacman-config.toml2
-rw-r--r--recipes-test/demo-config/secondary-config.bb22
-rw-r--r--recipes-test/demo-network-config/secondary-network-config.bb2
-rw-r--r--scripts/qemucommand.py1
6 files changed, 26 insertions, 11 deletions
diff --git a/recipes-sota/aktualizr/aktualizr_git.bb b/recipes-sota/aktualizr/aktualizr_git.bb
index d1fd088..65fa841 100644
--- a/recipes-sota/aktualizr/aktualizr_git.bb
+++ b/recipes-sota/aktualizr/aktualizr_git.bb
@@ -15,7 +15,7 @@ RDEPENDS_${PN}-ptest += "bash cmake curl net-tools python3-core python3-misc pyt
15PV = "1.0+git${SRCPV}" 15PV = "1.0+git${SRCPV}"
16PR = "7" 16PR = "7"
17 17
18GARAGE_SIGN_PV = "0.7.0-64-gc7c279f" 18GARAGE_SIGN_PV = "0.7.0-66-g94f52d1"
19 19
20SRC_URI = " \ 20SRC_URI = " \
21 gitsm://github.com/advancedtelematic/aktualizr;branch=${BRANCH};name=aktualizr \ 21 gitsm://github.com/advancedtelematic/aktualizr;branch=${BRANCH};name=aktualizr \
@@ -27,10 +27,10 @@ SRC_URI = " \
27 ${@ d.expand("https://ats-tuf-cli-releases.s3-eu-central-1.amazonaws.com/cli-${GARAGE_SIGN_PV}.tgz;unpack=0;name=garagesign") if d.getVar('GARAGE_SIGN_AUTOVERSION') != '1' else ''} \ 27 ${@ d.expand("https://ats-tuf-cli-releases.s3-eu-central-1.amazonaws.com/cli-${GARAGE_SIGN_PV}.tgz;unpack=0;name=garagesign") if d.getVar('GARAGE_SIGN_AUTOVERSION') != '1' else ''} \
28 " 28 "
29 29
30SRC_URI[garagesign.md5sum] = "36dedbf79f71cb697a18251ea121bcc6" 30SRC_URI[garagesign.md5sum] = "a7e17be337df92764a8e4bcbbbeff945"
31SRC_URI[garagesign.sha256sum] = "f0a8e4bb258fd65a6f1fe561132d5ab3fe25b76aec0f1873993dc65bf2167608" 31SRC_URI[garagesign.sha256sum] = "6c5136c8a769495175cf5daaebdfcd64985cca8ae829bb12ef5b92cf9af427c8"
32 32
33SRCREV = "5ead19cf8aefee44e929b7e98bc5aa63e0621aac" 33SRCREV = "56ac8dafb552b1d15638162ca14e0b818ed5e65f"
34BRANCH ?= "master" 34BRANCH ?= "master"
35 35
36S = "${WORKDIR}/git" 36S = "${WORKDIR}/git"
diff --git a/recipes-test/demo-config/files/30-ostree-pacman.toml b/recipes-test/demo-config/files/30-ostree-pacman.toml
deleted file mode 100644
index d2cf5b8..0000000
--- a/recipes-test/demo-config/files/30-ostree-pacman.toml
+++ /dev/null
@@ -1,2 +0,0 @@
1[pacman]
2type = "ostree"
diff --git a/recipes-test/demo-config/files/30-pacman-config.toml b/recipes-test/demo-config/files/30-pacman-config.toml
new file mode 100644
index 0000000..750cf5c
--- /dev/null
+++ b/recipes-test/demo-config/files/30-pacman-config.toml
@@ -0,0 +1,2 @@
1[pacman]
2type = @UPDATE_TYPE@
diff --git a/recipes-test/demo-config/secondary-config.bb b/recipes-test/demo-config/secondary-config.bb
index 58b18df..638f0ae 100644
--- a/recipes-test/demo-config/secondary-config.bb
+++ b/recipes-test/demo-config/secondary-config.bb
@@ -10,16 +10,32 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
10SECONDARY_SERIAL_ID ?= "" 10SECONDARY_SERIAL_ID ?= ""
11SOTA_HARDWARE_ID ?= "${MACHINE}-sndry" 11SOTA_HARDWARE_ID ?= "${MACHINE}-sndry"
12SECONDARY_HARDWARE_ID ?= "${SOTA_HARDWARE_ID}" 12SECONDARY_HARDWARE_ID ?= "${SOTA_HARDWARE_ID}"
13SECONDARY_UPDATE_TYPE ?= "ostree"
14
15UPDATE_TYPE = "${SECONDARY_UPDATE_TYPE}"
16python () {
17 update_type = d.getVar('UPDATE_TYPE')
18 if update_type not in [ 'ostree', 'file']:
19 bb.fatal('Unsupported type of an update specified for secondary: SECONDARY_UPDATE_TYPE = {}\n'
20 'Supported update types are: ostree and file'
21 .format(update_type))
22
23 if update_type == 'file':
24 d.setVar('UPDATE_TYPE', 'none')
25}
13 26
14SRC_URI = "\ 27SRC_URI = "\
15 file://30-ostree-pacman.toml \ 28 file://30-pacman-config.toml \
16 file://35-network-config.toml \ 29 file://35-network-config.toml \
17 file://45-id-config.toml \ 30 file://45-id-config.toml \
18 " 31 "
19 32
33
20do_install () { 34do_install () {
21 install -m 0700 -d ${D}${libdir}/sota/conf.d 35 install -m 0700 -d ${D}${libdir}/sota/conf.d
22 install -m 0644 ${WORKDIR}/30-ostree-pacman.toml ${D}${libdir}/sota/conf.d/30-ostree-pacman.toml 36
37 install -m 0644 ${WORKDIR}/30-pacman-config.toml ${D}${libdir}/sota/conf.d/30-pacman-config.toml
38 sed -i -e 's|@UPDATE_TYPE@|${UPDATE_TYPE}|g' ${D}${libdir}/sota/conf.d/30-pacman-config.toml
23 39
24 install -m 0644 ${WORKDIR}/35-network-config.toml ${D}${libdir}/sota/conf.d/35-network-config.toml 40 install -m 0644 ${WORKDIR}/35-network-config.toml ${D}${libdir}/sota/conf.d/35-network-config.toml
25 sed -i -e 's|@PORT@|${SECONDARY_PORT}|g' \ 41 sed -i -e 's|@PORT@|${SECONDARY_PORT}|g' \
@@ -36,7 +52,7 @@ do_install () {
36 52
37FILES_${PN} = " \ 53FILES_${PN} = " \
38 ${libdir}/sota/conf.d \ 54 ${libdir}/sota/conf.d \
39 ${libdir}/sota/conf.d/30-ostree-pacman.toml \ 55 ${libdir}/sota/conf.d/30-pacman-config.toml \
40 ${libdir}/sota/conf.d/35-network-config.toml \ 56 ${libdir}/sota/conf.d/35-network-config.toml \
41 ${libdir}/sota/conf.d/45-id-config.toml \ 57 ${libdir}/sota/conf.d/45-id-config.toml \
42 " 58 "
diff --git a/recipes-test/demo-network-config/secondary-network-config.bb b/recipes-test/demo-network-config/secondary-network-config.bb
index ca83d53..66641c3 100644
--- a/recipes-test/demo-network-config/secondary-network-config.bb
+++ b/recipes-test/demo-network-config/secondary-network-config.bb
@@ -21,7 +21,7 @@ do_install() {
21 21
22SECONDARY_IP ?= "10.0.3.2" 22SECONDARY_IP ?= "10.0.3.2"
23IP_ADDR = "${SECONDARY_IP}" 23IP_ADDR = "${SECONDARY_IP}"
24CONF_TYPE = "static" 24CONF_TYPE ?= "${@ 'multihomed' if d.getVar('MACHINE') == 'raspberrypi3' and d.getVar('RPI_WIFI_ENABLE') != '1' else 'static'}"
25 25
26require network-config.inc 26require network-config.inc
27 27
diff --git a/scripts/qemucommand.py b/scripts/qemucommand.py
index 86b5b9f..30929ac 100644
--- a/scripts/qemucommand.py
+++ b/scripts/qemucommand.py
@@ -40,7 +40,6 @@ def random_mac():
40 40
41class QemuCommand(object): 41class QemuCommand(object):
42 def __init__(self, args): 42 def __init__(self, args):
43 print(args)
44 self.enable_u_boot = True 43 self.enable_u_boot = True
45 self.dry_run = args.dry_run 44 self.dry_run = args.dry_run
46 self.overlay = args.overlay 45 self.overlay = args.overlay