diff options
-rw-r--r-- | lib/oeqa/selftest/cases/updater.py | 4 | ||||
-rwxr-xr-x | recipes-sota/aktualizr/aktualizr_git.bb | 3 |
2 files changed, 2 insertions, 5 deletions
diff --git a/lib/oeqa/selftest/cases/updater.py b/lib/oeqa/selftest/cases/updater.py index c7b18dd..e4b2fa5 100644 --- a/lib/oeqa/selftest/cases/updater.py +++ b/lib/oeqa/selftest/cases/updater.py | |||
@@ -102,9 +102,6 @@ class AktualizrToolsTests(OESelftestTestCase): | |||
102 | logger.info('Running bitbake to build aktualizr-native tools') | 102 | logger.info('Running bitbake to build aktualizr-native tools') |
103 | bitbake('aktualizr-native') | 103 | bitbake('aktualizr-native') |
104 | 104 | ||
105 | def test_implicit_writer_help(self): | ||
106 | akt_native_run(self, 'aktualizr_implicit_writer --help') | ||
107 | |||
108 | def test_cert_provider_help(self): | 105 | def test_cert_provider_help(self): |
109 | akt_native_run(self, 'aktualizr_cert_provider --help') | 106 | akt_native_run(self, 'aktualizr_cert_provider --help') |
110 | 107 | ||
@@ -228,6 +225,7 @@ class ManualControlTests(OESelftestTestCase): | |||
228 | self.assertIn(b'Fetched metadata: yes', stdout, | 225 | self.assertIn(b'Fetched metadata: yes', stdout, |
229 | 'Aktualizr should have run' + stderr.decode() + stdout.decode()) | 226 | 'Aktualizr should have run' + stderr.decode() + stdout.decode()) |
230 | 227 | ||
228 | |||
231 | class RpiTests(OESelftestTestCase): | 229 | class RpiTests(OESelftestTestCase): |
232 | 230 | ||
233 | def setUpLocal(self): | 231 | def setUpLocal(self): |
diff --git a/recipes-sota/aktualizr/aktualizr_git.bb b/recipes-sota/aktualizr/aktualizr_git.bb index 916ab4b..50a9f16 100755 --- a/recipes-sota/aktualizr/aktualizr_git.bb +++ b/recipes-sota/aktualizr/aktualizr_git.bb | |||
@@ -27,7 +27,7 @@ SRC_URI = " \ | |||
27 | file://aktualizr-serialcan.service \ | 27 | file://aktualizr-serialcan.service \ |
28 | " | 28 | " |
29 | 29 | ||
30 | SRCREV = "39acfec48d1cb91e7621c818ac177f6d3c73fecc" | 30 | SRCREV = "3c1c77c005fc1f872f1e12080528ed6f8a32bbf3" |
31 | BRANCH ?= "master" | 31 | BRANCH ?= "master" |
32 | 32 | ||
33 | S = "${WORKDIR}/git" | 33 | S = "${WORKDIR}/git" |
@@ -100,7 +100,6 @@ FILES_${PN}-examples = " \ | |||
100 | FILES_${PN}-host-tools = " \ | 100 | FILES_${PN}-host-tools = " \ |
101 | ${bindir}/aktualizr-repo \ | 101 | ${bindir}/aktualizr-repo \ |
102 | ${bindir}/aktualizr_cert_provider \ | 102 | ${bindir}/aktualizr_cert_provider \ |
103 | ${bindir}/aktualizr_implicit_writer \ | ||
104 | ${bindir}/garage-deploy \ | 103 | ${bindir}/garage-deploy \ |
105 | ${bindir}/garage-push \ | 104 | ${bindir}/garage-push \ |
106 | ${libdir}/sota/sota_autoprov.toml \ | 105 | ${libdir}/sota/sota_autoprov.toml \ |